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 Typefi Designer Plug-In for Adobe InDesign 1

With the installation of Typefi Designer, several panels, tools, menus and 
preferences are added to Adobe InDesign. Typefi Designer is a set of plug-
ins for InDesign used to transform regular InDesign templates or documents 
into files that can be used in the Typefi Publish automated publishing 
process. This guide is aimed at those who want to develop a Typefi 
template—either from an existing InDesign document, or starting with a 
blank document. You are the production designer.

Production designers use typical InDesign-type panels and techniques to add automation 
to the InDesign documents. 

Once an InDesign document is prepared for automation, it is uploaded as a template for a 
publishing project on the Typefi Server (see ‘Adding a template’ in Typefi Publish 6 - Server 
User Guide). The template is then specified within one or more Job Options (see ‘Job 
Options’ in Typefi Publish 6 - Server User Guide) so that content can be published. 

Typefi Designer performs several functions: user-based automation design, Typefi Engine-
controlled document automation, and (post-)editing of Typefi-specific additions. 

This part of the User Guide explains how to convert a layout or an existing InDesign 
template into a ‘dynamic’ template using Typefi Designer, and explains what automation 
options are available to you.

The structural information added to the templates is synchronised by the server with all 
content in the project—once the template is checked in to the server. This ensures authors 
have access to all the necessary tools in Typefi Writer to format their Word documents for 
automated publishing using Typefi Publish. 

Typefi Designer Plug-In 
for Adobe InDesign
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Typefi Designer for InDesign
The Typefi Designer plug-ins install new panels, an additional tool, extra menu commands 
and a number of Typefi preferences into Adobe InDesign. Each of the panels plays an 
important part in using Typefi Designer and is used to create dynamic InDesign templates 
for automated page composition using Typefi Publish. It also installs additional choices 
inside the InDesign dialogs that edit paragraph, character and table styles. The four Typefi 
panels in InDesign are:

 ■ Typefi Sections 
 ■ Typefi Fields
 ■ Typefi Elements
 ■ Typefi AutoFit

Typefi Panels

Typefi Sections
Sections are the divisions within a document that break it into logical chunks such as 
chapters. Sections specify which master pages to use, and in what order. (See "Typefi 
Sections" on page 16)

Typefi Fields 
Fields are text placeholders that automatically update if the author changes the definition. 
(See "Typefi Fields" on page 36)

Typefi Elements 
There are three types of elements: Fixed, Inline and Floating Elements. They can be formed 
from a single frame, or a group of frames, and can also include line or shape objects. In 
addition, Elements can contain Element Content or Image frames as well as Fields. (See 
"Elements" on page 10)

Typefi AutoFit 
The Typefi AutoFit tool allows project designers to define parent-child relationships 
between objects by clicking on them in sequence. When the parent object is moved 
or resized as a result of content fitting—for example, more text would make a frame 
grow—the child object will reposition or resize as well. The AutoFit panel is used to select 
from which point it may grow; and to provide limits on its growth/shrinkage. (See "Typefi 
AutoFit" on page 11)

The Typefi Sections panel and the Typefi Fields panel

The Typefi Elements panel and the Typefi AutoFit panel
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When you develop InDesign templates to be used for publishing with Typefi 
Publish, you must prepare and plan carefully.

Good template design requires you use InDesign best practices such as multiple master 
pages; hierarchical paragraph and character styles (styles based on other styles); table and 
cell styles; text variables for running headers; and so on.

Typefi’s automatic page composition process relies on the definition and setup of Typefi 
Sections that call on Master Pages which, in turn, determine the flow of content on 
document pages. Paragraph, Character, Object and Table styles enable the efficient 
assignment of text formatting, table formatting, and object-level formatting. Design 
elements are defined as Typefi Elements - which are automatically placed during the 
composition of a document. Standard InDesign frames are converted into Typefi Frames, 
which are receptacles for text and image content. A good place to start is analysis of the 
design…

Analysis of the design
The structural information added to an InDesign template defines the styling and other 
presentation information that is part of that design. Any two templates that have the same 
underlying structure can process the same content, even if those templates use different 
page sizes, element formatting, colours and fonts.

Four important components form the structure of a template:

 ■ Typefi Sections 
 ■ Typefi Fields
 ■ Typefi Elements 
 ■ Typefi AutoFit

Example: A publication might be published in different page sizes, such as 
US Letter and A4 for print, and a landscape layout intended for on-screen 
reading as well. EPUB output is now built-in to the Typefi process. Building 
multiple templates with identical structure but different layouts enables 
run-in of the same content with different output results.

Preparing InDesign Templates
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Paragraph, Character, and Table styles are also integral to the process. We will focus on 
these in-depth in this user guide.

Starting work on the template
You can create a Typefi template from a new document, or you can base it on an existing 
design or InDesign file. When creating a Typefi template from a new blank document, 
a good starting point is to develop a mock-up layout of the publication. This layout will 
then form the basis for the template creation. Styles are required for the design-driven 
composition Typefi Publish offers. 

Recurring items in a design - such as graphics with captions, margin notes, pull-outs, 
quotes etc. - are created and defined as Typefi Elements. These elements are accessible 
to the author in Word, positioned during page composition, and populated with author-
defined content.

We will use a mock-up as a starting point for the User Guide Typefi Project.

Master Pages
Before beginning work on the master pages for your template, consider the following: 
Does your design contain different parts? If so, what are these parts? These parts would 
probably become InDesign Sections as you are creating the document.

InDesign Master pages are created to be used in Typefi Sections and then Typefi Publish 
automatically creates an InDesign section for each Typefi Section used.

When looking at the example used here you might notice some of the following design 
decisions:

 ■ First Odd Page is Half Title Page
 ■ Next Even Page is Blank
 ■ Next Odd Page is Title Page
 ■ Next Even page is Copyright Information
 ■ Following the Copyright information a Table of Contents is inserted
 ■ This is followed by Preface, Introduction and Chapters
 ■ End Matter finishes the publication

In the example used:

 ■ A Chapter always starts on a right-hand page, and contains the chapter title, chapter number, and an 
image 

 ■ The next page contains a full-page photo

Sample publication
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 ■ The content text that follows after a chapter start always commences on a right page and has its own 
master applied to it

 ■ The continued-content text master contains the Publication Title in the left header and the chapter 
number and chapter title in the right header.

With other projects you will discover other patterns. For example, a Higher Education 
publication might be structured this way:

 ■ Chapters start on right pages
 ■ Next left page is a picture page
 ■ Next right page is a Learning Objectives page
 ■ Next left page continues Learning Objectives if needed
 ■ Next right page is where the Chapter text starts

Typefi Sections
Typefi Sections control how InDesign document sections (such as Chapters) are 
constructed and populated with content. They specify which InDesign Master pages they 
require during the composition process and in which order the master pages are used. 

Sections also specify the pagination settings—such as the style of the page numbering—
and whether the section numbering starts at 1 again, or continues from the previous 
section. They may also contain Section Fields (see "Section Type" on page 18)

Within the Section dialog, the Section fields can be activated (e.g. Chapter Title) so the 
author is prompted to fill them with data.

Layers
The use of layers in InDesign allows you to easily show and hide objects contained within 
a single layer. As an InDesign ‘best practice’ approach you should consider using layers for 
some of the following:

 ■ A Background layer to place objects that sit in the background, such as background tints behind pages 
or watermarks

 ■ A Running Headers or Footers Layer (if it is important that these items retain their order in the ‘stack’)

For Typefi content you could consider using:

 ■ A Main Content layer that is used for the run-in of the core body content
 ■ An Elements layer in which Typefi Floating and Fixed Elements are placed

Layers are a best practice method that helps control the stacking order of 
content in InDesign. Isolating content into separate layers ensures that 
there is consistency in the stacking order and that objects sit above or 
below other objects as expected. In addition, layers can be locked, which is 
a great way of isolating content types and makes it easier for you to select 
and edit content.

Review a sample of the required output and decide layout of chapter start 
pages. In this instance, chapters start on a right-hand page, followed 
by a graphic, and then the text starts on the next right-hand page.
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Styles
InDesign contains several different style-formatting tools, each used to provide consistent 
text formatting in the fastest possible way.

Paragraph and Character Styles
InDesign paragraph and character styles are highly efficient for text formatting. It is 
important that all of the content text provided by the author is formatted through use of 
paragraph and character styles in Word or XML. 

For those Typefi Publish projects that work in conjunction with Typefi Writer and Word, 
you can control (from within InDesign) which styles are to be made available to the 
authors in Word. 

Paragraph styles can make use of the next style feature (meaning you can control which 
style follows each paragraph style in the content document creation, although editors can 
over-ride this) as well as the nested style feature available in InDesign (which controls font 
and formatting changes within a paragraph).

When naming either Paragraph or Character Styles:

 ■ ensure the style name used is unique
 ■ do not use leading or trailing spaces in style names
 ■ do not use bullet characters or numbers only.

Tip: When defining character styles you should create styles that apply minimal 
formatting, such as font colour, all-caps, bold, italic, superscript or subscript—but leave 
font and size unspecified unless necessary. 

Avoid Word default style names − although InDesign has no restriction on style names, you should 
refrain from using style names such as: Heading 1, Heading 2, Heading 3, Title, Subtitle (case in-sensitive), 
as these style names are reserved by Microsoft Word and can cause unnecessary warnings within the 
job log due to the mismatch between XML (which is case-sensitive) and Word (which is not).  
To use a similar naming convention you could remove the space in these style names or add a prefix (e.g. 
A_Heading_1). The other problem with the built-in Word style names is that they change depending on 
the language version of Word (e.g. Titulo Uno instead of Heading 1).

When defining a paragraph style, you can specify the style that will follow it 
automatically if typing. This is referred to as the Next Style. Word allows the 
same specification, and will recognise it when the Typefi styles are imported 
(e.g. Bullet First to be followed by Bullets). 
If a paragraph needs varied character formatting, Nested Styles can be 
created to apply character styles automatically within the paragraph (e.g. 
the first word in the paragraph to be formatted as Bold). Word does not 
support this feature, so you will only see the result in the output PDF after 
running a print job.
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Typefi Inline Image Settings
With the installation of Typefi Designer plug-ins, the Paragraph and Character Style 
Options include an additional category: Typefi Inline Image Settings. The Typefi Inline 
Image Settings define how Typefi Designer will handle the sizing of inline images and the 
effect on the leading.

Inline images are images inserted at the cursor position inside a paragraph that behave as 
individual characters do. They can be positioned:

 ■ At the start of a paragraph
 ■ At the end of a paragraph
 ■ Anywhere inside a paragraph
 ■ In a separate single line paragraph. 

Image Height and Leading 
The Ignore Leading option retains the original leading for the line in which the Inline 
image is placed. If the Inline image height exceeds the leading height, the top of the 
graphic will overlap and obscure the text in preceding lines. 

Apply Auto Leading ensures that the leading for the line in which the Inline image 
is placed is set to auto. InDesign’s default Auto Leading setting is set as part of the 
Justification settings for a paragraph. The default setting is 120% of the font-size. For Inline 
graphics, the height of the graphic is the basis for the leading. For example if the Inline 
graphic is 10mm high, the leading will be set to 12mm.

Note: Leading is by default a character attribute in InDesign. Enabling the Apply Leading to Entire 
Paragraphs in the normal InDesign Type Preferences will result in a leading setting change for all lines of 
paragraphs - including lines containing Inline images.

Limit Inline Height to Font Size ensures that the height of the Inline image does not exceed 
the font size and images are only resized when their original height is larger than the font 
size. For example, if the original height of the image is smaller than the font size, the image 
is placed at its original size and not resized. If the original image height is larger than the 
font size the image is scaled down to match the font size.

Set Inline Height to Font Size resizes the height of the Inline image to the font size 
regardless of its original size at placement. For example when the original image height is 
smaller than the font size the image is scaled up. When the original image height is larger 
than the font size the image is scaled down.

Typefi Inline Image Settings are part of the paragraph style definition

Inline Image in single line paragraph with 
Apply Auto Leading option enabled

 (Original image size at left). Image Height and Leading 
set to Limit Inline Height to Font Size

 (Original image size at left). Image Height and 
Leading set to Set Inline Height to Font Size
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Limit Inline Height to Leading ensures that the height of the Inline image does not exceed 
the leading and images are only resized when their original height is larger than the 
leading. For example, if the original height of the image is smaller than the leading, the 
image is placed at its original size and not resized. If the original image height is larger 
than the leading the image is scaled down to match the leading.

When placing small pixel-based images and using the Set Inline Height to Font Size or Leading option, 
upscaling will result in loss of image quality and visible pixilation.

Set Inline Height to Leading resizes the height of the Inline image to the leading regardless 
of its original size at placement. For example when the original image height is smaller 
than the leading the image is scaled up. When the original image height is larger than the 
leading the image is scaled down.

Inline Image Settings for Character Styles
Inline Images are always positioned on the baseline of the line of text in which they are 
placed. In order to apply a baseline shift to an inline image, a character style must be 
used. Set the Typefi Inline Image Settings for this character style and set the baseline shift 
as part of this style.

A character style may only be applied to the inline graphic after it is inserted using the 
Typefi Writer.

Image Size and Text Frame Size 
The Image Size and Text Frame Size define the maximum width or height of an Inline 
image. If the original image exceeds this size, the image will be resized based on the 
Percentage of Text Frame Width or Percentage of Text Frame Height settings. For instance, 
if the Percentage of Text Frame Width is set to 25%, the width of the graphic will not 
exceed more than a quarter of the width of the Text Frame in which it is placed.

Expansion and Reduction Limits define the maximum and minimum upsize and downsize 
scaling percentage for an image during placement.

Maintain Aspect Ratio: When enabled, this ensures that images are resized 
proportionately.

 (Original image size at left). Image Height and 
Leading set to Limit Inline Height to Leading

 (Original image size at left). Image Height and 
Leading set to Set Inline Height to Leading

Inline image with baseline shift applied through character style settings.

Setting the size of an inline image within a particular paragraph style
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Export to TemplateXML
For Paragraph or Character Styles to be available to the author in Typefi Writer, you must 
enable the Export to TemplateXML option for the particular style in InDesign. For each 
Paragraph or Character style created that is not part of a style group (see "Style Groups" 
on page 9), the Export to TemplateXML option is enabled by default. 

The Export to Template XML option is disabled for style groups by default. This means 
that none of the styles that are part of the group will be accessible to the Typefi Writer 
in Word unless you choose to change it. Every Paragraph or Character style with Export 
to Template XML enabled is available to the author working on a project’s content with 
Typefi Writer in Word. Disable the Export to Template XML option for those styles that 
need not be accessible to the author in Typefi Writer (such as header, footer, and Table of 
Contents styles). 

To enable or disable the option for a Paragraph or Character Style:

 ■ Click the style name in the Paragraph or Character Styles list (or right-click on the name)
 ■ Select Export to TemplateXML from the Paragraph or Character Styles panel menu (or choose from the 

pop-up menu if right-clicked – see screenshot)

(Alternatively, select a Style Group containing a set of styles and enable or disable Export 
to TemplateXML for the entire Style Group). 

Note: The [Basic Paragraph] paragraph style and the [None] character style are never exported to 
Template XML. The command is disabled for these styles. Also, if you import paragraph styles from 
another template, the ‘Export to TemplateXML’ setting reverts to OFF. You must enable it again for 
those styles you want to make available to the authors.

Style Groups 
Style Groups are the InDesign way of organising organizing Paragraph or Character Styles 
into ‘folders’. To create one, select the required styles, and choose New Group from Styles 
in the Styles panel menu. You can drag styles in and out of these folders.

Before individual styles belonging to a style group can have their export options enabled 
or disabled, the Export to Template XML option for the entire Style Group must be 
enabled.

Enabling Export To TemplateXML for a Paragraph 
Style Group to make its styles available in Writer
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Using similarly-named styles could result in the Engine selecting the wrong style during page 
composition. Although InDesign’s Style Groups allows duplicate style names, Typefi Publish only 
references styles by name, and during text formatting, styles are assigned by the following logic: the 
Typefi 6 engine does a breadth-first traversal (http://en.wikipedia.org/wiki/Breadth-first_search) of the 
paragraph style groups. The last match wins, while the export flag is ignored. This is different behaviour 
to V5.

Object styles
Object styles are useful for many reasons, most of them relating to working more 
effectively in InDesign. When looking at Typefi structured formatting, you can use object 
styles for reasons other than efficient control of object appearances (such as stroke, fill, 
corner effects, paragraph styles, transparency settings etc.). In addition, bear in mind the 
use of object styles when:

 ■ Determining how Inline Elements are positioned during page composition (both Inline and custom 
anchored-object settings can come in handy) 

 ■ Assigning text wrap settings for Floating and Fixed Elements
 ■ Formatting of Element Image frames
 ■ Formatting of Element Content frames

Appearance and the text content of the frame can be formatted using an object style. 
If the paragraph style referenced in the object style contains reference to a next style 
and this feature is enabled, then the paragraph following the first style is automatically 
formatted with the relevant paragraph style. (Probably better left to authors to choose 
relevant styles).

Elements
Elements are design components that are not part of the main paragraph-based text flow 
but must be positioned within or near it. Typical elements include illustrations, figures and 
photos, margin content such as sidebars, callouts, quotes and notes, and graphics that can 
be used to mark a break between topics (see "Typefi Elements" on page 45).

Table Styles
Use InDesign Table Styles and Cell Styles for formatting of tables in your design (see 
"Creating Table Styles" on page 66).

The InDesign Object Styles panel, with examples of a variety 
of styles that control behaviour of Typefi elements

http://en.wikipedia.org/wiki/Breadth-first_search
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The Typefi AutoFit panel and tool are used to define relationships 
between objects, frames and lines, enable automatic text frame resize 
behaviours, and enforce minimum and maximum object size limits. AutoFit 
relationships, resize styles and min/max size limits enable designers to 
create dynamic page objects that react and respond automatically as 
content changes.

Features in Publish 6 include:

 ■ AutoFit relationships, resize styles, and size limits are preserved when exporting to a snippet file, an 
object library or InDesign Interchange (INX) or InDesign Markup (IDML) files

 ■ Corners are now supported as reference points for AutoFit relationships
 ■ Bi-directional and multi-parent relationships are also now supported
 ■ Relationships can now be created between a graphics frame and its content.

AutoFit tool
The AutoFit tool is used to create parent/child relationships between two objects. Resizing 
or moving the parent object simultaneously triggers a resize or movement of the child 
object. To create an AutoFit relationship between two objects:

 ■ Select the AutoFit tool from the toolbar
 ■ Using the parent pointer ( ), select a reference point of the bounding box of the first object
 ■ Using the child pointer ( ), select a reference point of the bounding box of the second object.

Relationships are between reference points of the bounding box, not anchor points on 
the object path. They can be created between objects that are placed on different layers, 
but not between inline objects, inline and page objects, or to an entire group (individual 
objects within a group are allowed). Complex relationships can be created by daisy-
chaining multiple parent/child relationships, using the same parent with multiple children 

Typefi AutoFit

The Typefi AutoFit tool—added to the Tools panel

AutoFit Cursors: Parent (left) and Child (right). The cursor changes 
from Parent to Child after you click an anchor point of an object.
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(one-to-many or many-to-one), or by defining bi-directional (parent-to-child and child-to-
parent) relationships.

Reference types
AutoFit relationships have different behaviours, depending on which reference point of 
the bounding box is selected for the child:

 ■ Centre reference points ( ) move, rather than resize, the child object.
 ■ Edge reference points ( ) resize a child object by stretching the frame along an invisible axis 

perpendicular to its edge.
 ■ Corner reference points ( ) resize an object by stretching the bounding box diagonally along an 

invisible axis radiating from the centre through its corner.

AutoFit will not scale stroke width or the frame contents when resizing objects. However, 
it can now create relationships between a graphics frame and its content. Objects may 
also have multiple relationships, where moving or resizing the parent point or object will 
trigger multiple child relationships (avoiding the need for many extra relationships).

Changing a relationship
To redefine an existing AutoFit parent/child relationship, simply move the child reference 
point or object—you can’t change a relationship by moving or resizing the parent because 
the child automatically resizes or moves according to the original relationship.

While AutoFit previously allowed you to invert a parent/child relationship by reversing the 
selection (using the AutoFit tool to reselect the child first, followed by the parent), these 
steps now create a bi-directional relationship, where moving or resizing either object 
triggers a change in the other object.

Removing relationships
AutoFit relationships can be removed by using the AutoFit tool to trace over an existing 
relationship—reselect the parent reference point first and then reselect the child. Or, 
choose Remove Relationships from the AutoFit panel menu to remove all relationships 
from the selected object(s).

When an AutoFit 
parent moves…

…its child also 
moves or resizes

The relationship between Parent and Child objects
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AutoFit panel 
The AutoFit panel is used to enforce minimum and maximum object size limits, and 
enable automatic resize styles for text frames. When combined with AutoFit parent/
child relationships, the AutoFit panel options enable the design of adaptive layouts that 
dynamically react to content changes. 

Minimum and maximum object size
The lower portion of the AutoFit panel enables you to limit the width and height of 
individual page objects. The two controls on the left affect the minimum width and 
height*, while the two controls on the right affect the maximum width and height.

You can type limits into the fields, or click the minimum or maximum width or height 
buttons (icons at the left of the entry fields) to copy the measurements of a selected 
object. When multiple objects are selected, AutoFit copies and applies the measurements 
of each object as unique (to each object) limits. This saves you having to repeat the 
process for each object. 

Removing object size limits
To remove a limit, delete the entered value or enter 0. To remove all limits from a selected 
object (including any AutoFit resize styles), choose Remove Attributes from the AutoFit 
panel menu.

Reference Point
The reference point setting icon is the little matrix of white boxes to the right of the Resize 
Style drop-down (see screenshot). It is very similar in purpose and behaviour to the similar 
one at the far left of the InDesign Control panel (in object mode). Selecting one of the 
nine reference points establishes the point about which any resizing will take place. The 
selected reference point changes to a black box. The equivalent point on the selected 
object(s) will remain fixed in the same position while resizing takes place. 

If a caption sits above an image, for instance, the text frame needs to grow upwards and 
perhaps to the right. In that case, the lower-left reference point would be selected before 
choosing the Resize Style.

* Regardless of the AutoFit minimum height, InDesign forces a minimum 3pt height for text frames.

reference point
resize style

baseline gap

min size max size

Keep Frame Size

TYPEFI AUTOFIT panel menu

The various sections of the Typefi AutoFit panel – here 
set to the default of no automatic resizing

Height Only (AutoFit)

TYPEFI AUTOFIT

Set current height
as minimum

Set current width
as minimum

Set current width
as maximum
Set current height
as maximum

The various buttons that set the minimum and 
maximum widths and heights to an existing object’s 
current size—only click those you want to lock
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Automatic resize styles
While you can manually fit a text frame to its content by double-clicking any frame 
handle, AutoFit-enabled frames dynamically resize as content changes. AutoFit can also 
automatically balance columns** for multi-column text frames. 

There are six types of AutoFit resize styles:

Keep Frame Size (default) does nothing and is equivalent to a normal InDesign text frame 
(Use this option to turn off automatic resizing)

Height Only (Autofit) (meaning ‘resize height only’) modifies a text frame so that it 
changes size depending on the amount of text it holds. You can choose which reference 
point remains fixed (see "Reference Point" on page 13), but the frame will only grow 
vertically. 

(Note: This choice is only present to accommodate legacy documents, and should not be 
used for new templates. Instead, use the following ‘Height Only’ choice.)

Height Only is the same as the InDesign Auto-Fit setting, and should be used for all new 
templates

Width Only is the same as the InDesign Auto-Fit setting

Height and Width is the same as the InDesign Auto-Fit setting

Height and Width (Keep Proportions) evenly distributes the height of the text frame 
above and below the centre point while fitting all text in the frame.

AutoFit attempts to resize text frames to fit all contained text. If the frame is not 
constrained by an AutoFit maximum height limit, the frame may extend to the limit of the 
pasteboard. In addition, if the frame contains an inline object whose height is greater than 
allowed by the AutoFit or pasteboard limit, or if it contains text that is wider than a column 
(due to Hyphenation Settings, nonbreaking spaces, or the No Break character attribute), 
the frame will extend only to the last displayable line of text.

Removing resize styles
To remove a resize style, change the frame to Keep Frame Size or choose Remove 
Attributes from the AutoFit panel menu (the latter option will also remove any min or 
max size limits and any applied max vertical gap).

** AutoFit uses the native ‘Balance Columns’ feature in InDesign CS6, which is controlled by Object > Text 
Frame Options > Balance Columns.

The AutoFit panel – here set to resize from the top down, with a minimum 
height (8pt) and width (242pt) plus a maximum height (36pt)

Two versions of the AutoFit panel, including the deprecated 
‘Height Only (AutoFit)’, which then reveals the ‘Maximum 
Vertical Gap’ setting, now also deprecated.
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Vertical gap
The vertical gap setting provides additional padding, up to the value specified, between 
the top or bottom (or both) of the frame depending on its Vertical Justification options. 
This is only editable if “Height Only (AutoFit) is selected, and it is now deprecated. (This is 
better done using the InDesign Text Frame options).

Publish 6 no longer calculates and automatically applies a maximum vertical gap when 
creating an AutoFit parent reference point on a text frame.

Scripting AutoFit
AutoFit fully supports scripting as part of Typefi Designer. You can use the object browser 
offered by the various languages to examine the objects and methods added by AutoFit. 
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Typefi Sections are similar to InDesign Sections you might use during 
manual page-compositions. They will assign particular master page designs 
to document pages; define the type of section content; allow activation of 
section fields; define the page numbering method; etc..

They define the order in which master pages will be used during automated page 
composition as Typefi Publish inserts content in the InDesign document that it creates. 
Additionally, Sections define the page numbering method used, and whether any Section 
Field data should be inserted (see "Typefi Fields" on page 36).

Designing a Section
Prior to creating a new section, review the InDesign design file and determine how you 
would construct a section. For example, imagine that each chapter in your publication is a 
book section. Each new chapter must start on a right hand page (or ‘recto’), which means 
that the preceding chapter might require insertion of a filler page when it ends on a right 
hand page. This first page of a new chapter has its own significant design. The rest of the 
editorial pages that form part of the chapter will reference their own master page, and 
might have running headers or footers.

To create a section, consider how the section would be constructed using InDesign master 
pages you have already generated in your document.

Let’s look at some examples.

A chapter starts on a right hand page and has the Cs-Chapter Start master page applied 
to it. This master page contains a Fixed Element (see "Fixed Elements" on page 45) for 
the graphic, and two Section Fields (see "Section Name" on page 18) are inserted for the 
Chapter Title and Number.

Typefi Sections

Cs – Chapter Start master pages
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The rest of the pages in the chapter are created using the Cn-Chapter Next master page. 
These pages are repeated until there is no more content for the chapter. As a rule the rest 
of the pages must start on a right page.

The header on the left master page contains a Project Field (BookTitle) (see "Typefi Fields" 
on page 36). The header on the right master page contains two Section Fields for the 
Chapter Title and Number. Both left and right master also include Main Story frames. 

 ■ A single filler page is used immediately following the right page that starts a chapter, so that the textual 
pages will start on a right hand page and no blank pages appear in the document.

 ■ A blank filler page is used when a textual section finished on a right page, as the next new chapter must 
start on a right page as well.

Before defining a new Typefi section ensure that:

 ■ All relevant Master Pages required for the creation of a Typefi Section have been created, including ‘filler’ 
masters

 ■ Masters used in a Main Story Section (not TOC or Index) contain a Main Story frame (see page 25)
 ■ Masters used in a Table of Contents Section contain a Table of Contents frame
 ■ Masters used in an Index contain an Index frame
 ■ Fixed Elements are placed only on Master Pages that are used once per Section
 ■ Section Fields such as a ChapterTitle or ChapterNumber are inserted where relevant—for instance, in 

headers or footers and title pages
 ■ Project Fields are added where relevant—for instance, BookTitle on cover page, and in a footer.

New Typefi Section 
To define a new Typefi Section:

 ■ Select New Typefi Section… from the Typefi Sections panel menu (Window > Typefi)

(Alternatively, click the New Section icon at the bottom of the panel).

The Typefi Section Options dialog box is displayed.

The Typefi Section Options defines how a section is named (Section Name), what type 
of section it is (Main Story, Table of Contents, or Index); what pagination to use (Masters), 
what Page Numbering to use, and whether any Section Fields are part of the section.

 ■ Next enter the Section Name (see "Section Name" on page 18)
 ■ Set the Section Type (see "Section Type" on page 18)
 ■ Set the Pages settings
 ■ Enable or Disable Repeat Last Master option
 ■ Set the Page Numbering settings
 ■ Then click Fields and choose the Field settings

Cn-Chapter Next.

Typefi Section Type and the Add Master button (both circled)
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 ■ Click OK to save the Section to the Typefi Sections Panel.

Section Name
The section name is a unique name. Use a meaningful name, as the author must start 
each Word document by inserting a Typefi Section. The Section Names are also referred 
to by name at the Typefi project level on the Typefi Publish Server (see “Projects” in Typefi 
Publish 6 - Server User Guide ).

Section Type
There are three Section Types, Main Story, Table of Contents, and Index.

 ■ Main Story sections are used for general page composition and content run-in
 ■ Table of Contents sections are used for the run-in of a Table of Contents
 ■ Index sections are used to hold an automatically-generated index

Section Type vs. Content
The choice of section type establishes which type of content takes precedence in 
determining whether or not more pages must be inserted during page composition. A 
Main Story section contains the main body of the content; a Table of Contents section 
contains the text that is generated for the Table of Contents; and an Index contains the 
automatically-generated index entries and their page numbers. Typefi continues to add 
pages during page composition until the content type that has precedence has all been 
formatted and placed (usually the Main Story).

Section Type vs. Typefi Frame Type
In order for Typefi Publish to be able to insert content and generate continuous pages, 
the Typefi Section defines the sequence in which master page designs are applied to 
document pages during composition. These master pages must contain Main Story, Table 
of Contents, or Index text frames. The main body of content fills Main Story frames; the 
Table of Contents text fills Table of Contents frames; and the Index entries fill the Index 
frames (see "Typefi Frame types" on page 25). The goal of the Typefi Engine is to add as 
many pages as necessary to have no text overset on the type of frame it is focused on.

When the Typefi Engine cannot find a Main Story frame in a Main Story section type after 
it created a page from the possible master pages, the Engine stops the pagination of the 
section. Similarly, when the Engine cannot find a Table of Contents frame in a Table of 
Contents section, it will not continue.



 Typefi Sections 19

Main Story section and Table of Contents frames
The first Master used by a Main Story section may contain a Table of Contents frame. When 
the Typefi Engine encounters such a frame, it will trigger the Table of Contents creation 
and insert the text into that frame. Such a Table of Contents frame could be used for 
creation of a short section-based Table of Contents for instance.

If the TOC text exceeds the frame length, the text becomes overset when:
a) There is more TOC content, but no more Main Story content, which means the Engine 

stops adding more pages.
b) There is more TOC content, but the master page designs used to run-in the overset text 

for the Main Story frames do not contain TOC frames.

Table of Contents Section and Main Story frames
A TOC Section First Master may contain a Main Story frame. When the Typefi Engine 
encounters such a frame, it inserts main body content added by the author into the Main 
Story frame following the Table of Contents Section insert. (Such a Main Story frame could, 
for example, be used when writing up an introduction at the start of each chapter.)

If the Main Story text exceeds the frame length, the text in this Main Story frame becomes 
overset when:
a) There is more Main Story content, but no more Table of Contents content, which means 

the Engine stops adding more pages.
b) There is more Main Story content, but the master pages used to run-in the overset text 

for the Table of Contents do not contain Main Story frames.

Pages 
The next part of the Section Options dialog sets the order in which Master pages are used 
and repeated as content is flowed into the document.

There is no limit to the number of Master Pages that can be applied to document pages 
during page-composition. Master pages are used in a top-down order. This means that the 
first Master page listed is used first, then the next one and so on.

Assigning a Master Page to a Section
A New Typefi Section always defaults to the inclusion of the first Master page listed in the 
Pages Panel.

Using short section-based TOCs requires publishing to a Book rather than a 
Single Document (see Typefi Publish 6 - Server User Guide).

Adding more Master Pages to the initial Master 
page that appears by default
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To assign Master Page(s) to a section:

 ■ Select the Master to be used
 ■ Set the Starts On preferences (see "Starts On" on page 20)
 ■ Set the Filler preference (see "Filler Master" on page 21).

To assign more master page(s) to a section:

 ■ Click the Add Master button
 ■ Then set the Master page, Starts On and Filler settings
 ■ Continue to click Add Master, until you’ve added all necessary master pages.

For instance, for a Chapter section of a publication you might set the Pages settings to use 
a number of master pages, including a Filler page to complete a chapter with a verso page 
before the next chapter starts on a recto page.

STARTS ON

Starts On determines whether the first page of a section starts on left or right side, or 
either side, and whether or not all pages in the master spread are used. See the following 
table for a detailed overview of the Start On options.

‘Starts On’ option Description

Either Side The first page of the section can start on either a Left or Right 
page and is determined by the last page of the previous 
section. For instance, if the previous section finishes on a Right 
page, then the section will start on a Left page.

Right Side The first page of the section must be a Right page, regardless 
of whether the previous section ends on a Left or Right page. 
The Left page is not used and depending on further settings 
the Next Master might be used or a last used master repeated.

Left Side The first page of the section must be a Left page, regardless 
of whether the previous section ends on a Left or Right page. 
The Right page is not used and depending on further settings 
the Next Master might be used or a last used master repeated.

Either Side, Use All Pages The first page of a section can start on either a Left or Right 
page depending on the last page of the previous section. 
Both Left and Right page must be used. This means that if the 
section starts on a Left page, the Right page will be added 
whether there is content for it or not (or vice versa).

Right Side, Use All pages The first page of a section must be a Right page. Both Left and 
Right page must be used. This means that the Left Page will 
be inserted whether there is content for it or not.

Chapter Section set to use three different master pages 
during page composition, one being a Filler
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‘Starts On’ option Description

Left Side, Use All pages The first page of a section must be a Left page. Both Left and 
Right pages must be used. This means that the Right Page will 
be inserted whether there is content for it or not.

FILLER MASTER

A Filler Master is a page that is inserted at the end of a section to ensure the following 
section can start on a required left or right hand page. For instance, if the next master 
must start on a Right page, and the previous page is a Right page, then a filler master 
would insert one additional page. The filler master can be a specifically designed master 
page or [None], which inserts a blank page. (Since [None] is the default, it can often be left 
unchanged).

Repeat Last Master 
The Repeat Last Master option, when enabled, will continue to apply the last master page 
design during page composition as pages are added to the InDesign document that is 
being created. The Typefi Engine continues to add pages to the document until all content 
is inserted (see "Section Type vs. Typefi Frame Type" on page 18).

Page Numbering 
The Restart Page Numbering option determines whether the page number of a section 
starts at ‘1’ or follows on from the previous section’s page numbering. This setting 
automatically sets the Start Page Numbering at option in InDesign’s Numbering & Section 
Options.

Style
The Page Numbering Style defines the type of page numbering that is used for a Section. 
The default style is Arabic. Alternate numbering styles are Roman numerals (i, ii, iii etc.) 
and Alphanumeric (a, b, c etc.) in lower- and upper-case variants. The Page Numbering 
Style setting automatically sets the Page Numbering > Style option in InDesign’s 
Numbering & Section Options.

To edit the Page Numbering Style for a section, select the preferred numbering style from 
the Style drop-down.

Repeat Last Master enabled—Tn-Chapter next 
will repeat as needed in this example

Page Numbering settings in Section Options dialog.

Section Page Numbering Style and Mode choices
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Mode
The Page Numbering Mode is used to define at which stage automated page numbering 
is reset to ‘1’:

Continue from Previous Section means that the page numbering follows-on from the last 
page number of the previous section that is being published, regardless of which section 
is preceding the defined section. For example, you might have a document that contains 
a special Back Matter Section that needs to continue its page numbering from the last 
Chapter of the document.

Restart at Every Section means that the page numbering is reset to ‘1’ each time the 
defined section appears in the publication. 

Restart at First Section means that page numbering is reset to ‘1’ for the first occurrence in 
the publication of the defined section. Any sections following this section continue their 
numbering sequentially, including any other occurrence of the same type of section

You could use this setting when the first chapter of a publication restarts its page 
numbering at ‘1’ after the usual front matter, and the following chapters continue their 
page numbering.

Section Prefix
The Prefix is a label that precedes the automatic page numbering in InDesign. The prefix 
value will also appear in a Table of Contents that includes page numbers.

 ■ All of the Prefix data precedes the placement of the page-numbers
 ■ Text Before and Text After allows for the inclusion of literal text strings (any text you want)
 ■ Field data is sourced from either a Section or a Project Field value
 ■ During page composition in InDesign the Prefix data is inserted as: Text Before  + Field data + Text 

After + Current Page Number.

Section Marker
When a Section Marker has been included in a Text Frame on a Master Page (Type menu > 
Insert Special Characters > Markers) the Section Marker value added will appear in its 
place on the document pages. 

 ■ All of the Marker data entered populates the Section Marker value in InDesign’s Numbering & Section 
Options during page composition (see screenshot)

 ■ Text Before and Text After allows for the inclusion of literal text strings
 ■ Field data is sourced from either a Section or a Project Field value

Choosing Section Markers for page numbering within a section—
ChapterTitle will preceed the page number in this example

InDesign Numbering & Section Options, where the Typefi 
Section Prefix and Marker will be placed as data



 Typefi Sections 23

 ■ During page composition in InDesign the Section Marker data is inserted as: Text Before + Field data + 
Text After. 

Prefix and Section Marker values are non-changeable values after being set by the InDesign Section 
Options. When you’re looking at using a changeable prefix or section marker in your designs, consider 
using a Typefi Section Field instead. 

Assigning Section Fields to a Section
Any fields that are part of the Section must be included in the Section. Fields are discussed 
in depth in their own chapter (see "Typefi Fields" on page 36).

To assign Section Fields to a Section:

 ■ Click Fields in the Typefi Section Options dialog to display the Field section of the dialog
 ■ Enable those Fields that are to be used by the Section.

Or alternatively, if the Section Field has not yet been defined:

 ■ Define a new Section Field by clicking the New Field icon at the bottom of the dialog
 ■ Name the Field.

For all of the Fields assigned to the Section, the author is prompted to provide input data 
when inserting this element with Typefi Writer in Word.

Fields may be used to store hidden meta-data that does not appear in the final output, but is required for the 
content and the XML into which the content is ultimately transformed. Project Fields are useful in Jobs run on 
the server, as they can be used to label the particular Job.

DELETING A SECTION FIELD

The Field area in the Typefi Section Options can also be used to delete Section Fields. 
However, this only works for Section Fields you’ve just defined in Typefi Section Options. 
Fields added to the Section Fields list whilst the Typefi Section Options dialog is open are 
listed in italics when they are not selected, so that they can be distinguished from any 
Fields defined earlier.

If any other Section Fields need to be deleted please refer to page 43.

To delete a field:

 ■ Enable the field you’ve added earlier
 ■ Click the Delete icon at the bottom of the Fields list (see screenshot).

Assigning Section fields to a Section

Deleting a selected field using the Rubbish Bin icon in the Fields panel
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Apply Section 
You can apply Typefi Sections in InDesign if needed. The Apply Section command controls 
whether a section starts on a left or right page, but does not apply Master page designs to 
master pages that are part of a section. Typefi Section field behaviour can be tested in the 
InDesign document when a Section has been applied.

To Apply a Typefi Section:

 ■ Show the Typefi Sections panel (Window >Typefi menu)
 ■ Select the document page in the Pages panel that is to become the start page of a section
 ■ From the Typefi Sections panel menu choose Apply Section
 ■ The Typefi Section has now been applied.

Break Link to Section 
Breaking a link to a Typefi Section does not remove the InDesign Section marker that has 
been added to a section, nor does it alter the document pagination.

To break the link to a Section that has been applied:

 ■ Show the Typefi Sections panel (Window >Typefi menu)
 ■ Select the document page in the Pages panel that is the start page of a section
 ■ Select Break Link to Section from the panel’s menu

(Alternatively, click Break Link to Section at the bottom of the Typefi Section panel).

The pages in the section are now no longer associated with the Typefi Section.

Delete Section
You may find you no longer require a particular Typefi Section, and would like to remove it 
from the template…

To delete a Section from the Typefi Section Panel:

 ■ Show the Typefi Sections panel (Window >Typefi menu)
 ■ Select the Section to be removed
 ■ Choose Delete Section from the panel menu

(Alternatively, click the Delete Section icon at the bottom of the panel).

 ■ Click OK to delete the Section.

The Section will no longer be listed in the Typefi Sections panel and Applied Section 
references are removed from the document.

Apply Section command and button

Break Link to Section.

The Delete Section command and icon in the Sections panel
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Frames are containers for text or other objects, such as graphics. InDesign 
defines three types of content for frames: Text, Graphic and Unassigned. 
Typefi Frames are InDesign frames with additional attributes that allow them 
to receive content dynamically during page-composition.

Typefi Frame types
There are five types of Typefi Frames:

 ■ Main Story
 ■ Table of Contents
 ■ Index
 ■ Element Image
 ■ Element Content

To help distinguish Typefi Frames from InDesign frames, the borders of the frames are 
coloured by default with a 2.5 pt stroke (see "Typefi Borders" on page 88).

Frame Type Border Colour

Main Story Red

Table of Contents Dark Blue

Index Violet

Element Content Cyan

Element Image Yellow

Borders only display when View > Show Frame Edges is enabled, Object> Overprint 
Preview is disabled, and the document Screen Mode is set to Normal. The default Typefi 
Border colours and thickness can be altered by editing the Typefi Border preferences.

When Typefi Publish flows content into Typefi frames, existing content that 
appears in these frames is automatically replaced during population of the 
frames at time of page composition.

Typefi Frames
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Main Story
Main Story frames are the more common Text Frame type seen in Typefi Templates. Main 
Story frames are placed on Master Pages used by Typefi Sections.

Typefi publishes content into Sections and uses the Master Pages defined by the sections 
during the composition process to create document pages. Typefi Publish automatically 
runs content into Main Story frames, creating new document pages and filling these 
frames, until all content is placed according to the rules defined in a Main Story Section 
(see "Section Type" on page 18).

An exception applies if a Table of Contents (TOC) section contains a Main Story frame on 
only the first page of the section and not the following pages. In this case the main story 
content only runs into the first page of the section, even if the TOC runs over multiple 
pages. However, if a TOC section does include Main Story frames on following pages, then 
the Typefi Designer plug-in will automatically run main story content into following pages 
for the length of the TOC section.

Creating a Main Story frame
To create a Main Story frame:

 ■ Open the Master page and insert a normal InDesign Text Frame on the left and right master
 ■ Select the Text Frame with the selection tool
 ■ Choose Typefi Frame Type > Main Story from the Object menu (or right-click the frame and choose it 

from the context menu)
 ■ Click OK.

(Alternatively, right-click the frame and select Typefi Frame Type > Main Story from the 
contextual menu that displays).

The Main Story Frame property has now been applied and identified by its thick red frame 
edge. 

First Paragraph Style (Deprecated)
The choice of First Paragraph Style (for users of previous versions) no longer exists. It’s 
only available for legacy (converted) documents and then only on frames where the 
setting was previously set to anything other than [None]. As soon as you change the First 
Paragraph Style Override of a Main Story or Element Text frame to [None] in a Typefi 6 
document, the UI to set the First Paragraph Style Override for that frame is hidden (it can 
be restored via the Designer scripting interface).

Right-click on a frame to bring up the Typefi Frame 
Type choices (or use the Object menu)

Main Story frame property applied to text frames 
on Left and Right master pages.
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Table of Contents
Table of Contents (TOC) frames are special text frames designed specifically to be 
populated with table of contents data. The data that fills the TOC frames is based on the 
InDesign Table of Content style assigned to the frames. Pagination of TOC frames occurs 
after all other pages have been composed. This is because all of the source data that is 
going to be used to populate the TOC frames must be laid out in the paginated document 
first so that their assigned page location is known.

TOCs may be created at publication or section-level. Publication-level TOCs source their 
content from all sections of a publication. Section-level TOCs source their content from the 
section to which they belong.

About section level TOCs: as InDesign does not permit a TOC to be targeted at a particular page 
range, the preferred method for creating section-level TOCs is to ensure each section is produced as 
an individual InDesign document that ultimately will be bound into a book. To automatically compose 
multiple sections and build section-level TOCs use the Create Book option in the Job Options for page 
composition (see Job Options in the Typefi Publish Server Guide).

Like Main Story frames, Table of Contents frames are placed on master pages that are used 
as part of Sections.

Table of Contents Styles
Table of Contents are always based on InDesign’s native Table of Contents Styles. 

Start by creating one or more Table of Contents Styles as part of your InDesign template 
prior to assigning the Typefi Frame Type - Table of Contents to a Text Frame. 

To create a Table of Content Style in InDesign:

 ■ Select Layout > Table of Contents Styles
 ■ Click New
 ■ Name the Style (e.g. TOC_Figures).

Under the Other Styles list, all of the paragraph styles used in the document are listed. 
From this list:

 ■ Select any styles that are applied to content you’d like to see extracted into the fully populated TOC 
frame

 ■ Click Add, to add these styles to the Include Paragraph Styles list.
A Table of Contents Style created for a specific Typefi project



 Typefi Frames 28

Using the Table of Contents Styles dialog you can set additional settings for formatting of 
the TOC data that is extracted from your document pages during page composition, such 
as the position of the page number, the style with which particular data is formatted and 
the level. For full details on all of the options and settings available for creation of Table of 
Contents Styles in InDesign, please refer to InDesign’s Help menu. 

Tip: If you’ve created separate paragraph styles for formatting of the various content levels in your 
Table of Contents, consider placing these in a separate Style Group that has Export To TemplateXML 
disabled. None of the TOC paragraph styles need to be accessible in the Typefi Writer in Word.

When used within TOC sections (see "Section Type" on page 18), Typefi Publish 
automatically generates the table of contents, creating new Table of Contents frames and 
pages until all TOC content is placed. This happens after all other Main Story sections are 
paginated. 

Note: Because TOC sections are created as the last step in the process, Typefi Publish forces the first 
Main Story section following a TOC section to start on the right side and does not allow pages to 
‘shuffle’. This may result in a filler master being inserted after a TOC section.

Creating a Table of Contents (TOC) frame
To create a TOC frame:

 ■ Open the Master page and insert a normal InDesign text frame
 ■ Select the Text Frame with the selection tool
 ■ Choose Typefi Frame Type > Table of Contents from the Object menu. 

(Alternatively, right-click the frame and select Typefi Frame Type > Table of Contents from 
the contextual menu that displays).

The Table of Contents Options dialog prompts you to select the InDesign Table of 
Contents Style on which to base the Typefi TOC.

 ■ Select the appropriate InDesign TOC style
 ■ Click OK.

The Table of Contents Frame property is applied and is recognisable by its thick dark blue 
frame border, and the name of the particular TOC style appears as a label in the lower-
right corner (see screenshot).

Table of Contents Options

Typefi Table of Contents frame property applied to text frame on 
TOC Contents master page (the TOC style name is circled)
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About TOC frames
A TOC frame can also be included on a Main Story master page in the document, and 
can share that page with a Main Story frame. This permits inclusion of smaller TOCs 
throughout a document. For instance, you could use this to include a section-based TOC 
on the first page of a new section. The section itself doesn’t need to be defined as a TOC 
Section (see also "Section Type" on page 18). Such a TOC frame will not thread onto 
further pages if the TOC becomes overset on the first page of the section (The TOC frame 
will thread to a next page of a section if there is another page in the section that uses a 
TOC frame for the same TOC style. Within a Main Story section, the Engine will not add 
pages just because there is an overset TOC frame). InDesign does not permit a TOC to be 
targeted at a particular page range, so the preferred method for creating section-level 
TOCs is to ensure they are separate documents that ultimately will be bound into a book. 
You can select a Book output from the Job Options in the Server (see Typefi Systems Server 
Guide).

Use multiple TOC frames to generate different TOC types such as Table of Tables, Table 
of Figures and so on. Due to the limitations of InDesign’s TOC styles, these must currently 
exist as separate frames. Although additional TOCs can be appended to the main TOC, this 
would require a Typefi feature enhancement to be added to your project in the form of a 
script. 

Index
While some organisations prefer to create indexes manually after a document has been 
produced, it is easy to produce an automatic index with all the required features of a 
traditional index. Typefi Publish harnesses the power of the InDesign native indexing 
feature, and allows authors to use the standard Microsoft Word indexing feature. 

Typefi Index Sections
A template needs to have a Typefi Index Section added to it that has its own master pages 
containing Index Frames. Index frames are the new Typefi Frame type now included in 
Typefi Publish 6.

Index Paragraph Styles
The index will be styled with the default InDesign Index styles, so it is necessary to create 
and modify those style definitions if you want the index to look different to the standard 
InDesign index. Those styles are named Index Title, Index Section Head, Index Level 1, 

The new Typefi Index section type (drop-down menu circled to show 
the new choice) uses master pages with frame type set as ‘Index’ 
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Index Level 2, and so on (see screenshot). Depending on how many levels of ‘nesting’ are 
needed, more styles may be defined. (Word only offers nesting to one level in its indexing 
dialog.)

Generate Index
The index dialog allows the assignment of paragraph styles to the index. To access it:

 ■ Open the Index panel – Window/Type & Tables/Index
 ■ Choose Generate Index from the Index panel menu
 ■ Click the More Options button under the Cancel button
 ■ Accept the default settings or modify as necessary
 ■ Click OK.

The index styles will be generated automatically when the job is run by the author.

The index dialog is a standard InDesign feature. For more information about indexing in InDesign, see 
http://tinyurl.com/indesign-indexing

More levels of nesting within the index are available in InDesign than are offered in Word. 
Therefore, you only need to create the following paragraph styles:

 ■ Index Title – the main title: ‘Index’ (which could be set to span columns, for instance)
 ■ Index Section Head – the letters in alphabetical order that form headings for the index entries
 ■ Index Level 1 – the basic index entries followed by page numbers
 ■ Index Level 2 – the ‘nested’ index entries that appear under a topic heading

Another modification you may need to make is to the default sort order. The standard 
sort order places symbols before Roman text characters, followed by numbers, etc. (see 
screenshot). You can also choose to include or not include certain categories.

Creating an Index frame
To create an Index frame:

 ■ Open the Master page and insert a normal InDesign text frame
 ■ Select the Text Frame with the selection tool
 ■ Choose Typefi Frame Type > Index from the Object menu. 

(Alternatively, right-click the frame and select Typefi Frame Type > Index from the 
contextual menu that displays).

The InDesign Index dialog (expanded to show all options)

The default sort order of an InDesign index – click 
the up/down arrows to change the order

http://tinyurl.com/indesign-indexing
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The Index Frame Type property has now been applied and identified by its thick 
violet frame edge. (You may want to choose a multi-column format—as seen in the 
screenshot—for the text frame using the standard InDesign Text Frame Options dialog, as 
most indexes use two- or three-column layouts.)

The Index Master can now be used to create a new Typefi Section called Index (or 
whatever is needed) that will use the master to create the index pages (see "Designing a 
Section" on page 16). As with the Table of Contents, you may need a second master for 
subsequent index pages. The author does all the indexing preparation using the standard 
Word indexing feature.

Element Image
Element Image frames are placeholder graphic frames used within Typefi Elements (see 
"Element creation process" on page 46) and provide a number of options to control the 
fitting and placement of images. For an Element Image frame to become active it must be 
part of an element and it must have an image linked to it from content. 

An Element Image frame can also be used directly on a master page. In that case, an inline image from 
the content of the main story could be placed in that frame rather than being placed as an InDesign 
inline image (a feature since the first version of Typefi).

Creating an Element Image Frame 
To create an Element Image frame:

 ■ Select an InDesign graphic frame with the selection tool
 ■ From the Object menu select Typefi Frame Type > Element Image

(Alternatively, right-click the frame and select Typefi Frame Type > Element Image, or 
select Element Image from the Typefi Frame Type submenu in the Typefi Elements panel 
menu).

The Element Image Options dialog prompts you to select the image fitting, expansion and 
reduction options.

 ■ Select the appropriate Fitting setting
 ■ Set the Expand From option22
 ■ Set the Expansion and Reduction Limits
 ■ Click OK.

Applying the new Typefi Index Frame Type to a text 
frame (formatted to be a three-column object)

Element Image Options, including a renamed Fitting option

Element Image Frame (left) and image to be placed 
within using Fitting options (right)
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The Element Image Frame property has now been applied and is distinguished by its 2.5pt 
yellow frame border. 

Element Image Options
There are a number of Element Image Options to choose from, such as Fitting, Expand 
From, Expansion Limit, and Reduction Limit, all with many possible settings.

Fitting
The Fitting options automatically adjust the size of an image or its frame when placing a 
graphic into the element image frame during page composition. 

Note: Frame resize behaviour may also be dependent on the inclusion of minimum or maximum frame 
width and height settings applied to the frame by AutoFit.

Here are the results of the image above being placed in the above image frame with 
different fitting settings (but all resizing from Top Left):

1: Fit Frame to Content 2: Fit Content to Frame 3: Fit Content Proportionally 4: Fill Frame Proportionally 5: Fit Content then Frame Proportionally

1) FIT FRAME TO CONTENT

Fit Frame to Content resizes the Element Image frame to the full image size, therefore the 
image is always placed at 100% (see screenshot)
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2) FIT CONTENT TO FRAME

Fit Content to Frame resizes the image to fit in the Element Image frame. No frame resizing 
occurs. Where the image proportions don’t match the frame proportions the image is 
placed non-proportionally and may appear distorted.

3) FIT CONTENT PROPORTIONALLY

Fit Content Proportionally resizes the image to fit in the Element Image frame. The image 
is resized proportionally. No frame resizing occurs, perhaps resulting in part of the frame 
appearing empty if the proportions of the image differ from those of the frame.

(This setting could be used where image frame sizes must remain consistent throughout 
the page composition and no part of the image may be masked. This setting is suitable for 
instances of illustrative or technical graphics that must be placed without cropping.)

4) FILL FRAME PROPORTIONALLY

Fill Frame Proportionally resizes the image to fill the entire Element Image Frame. The 
image is resized proportionally. No frame resizing occurs, often resulting in part of the 
image being masked out.

(This setting could be used where image frame sizes must remain consistent throughout 
the page composition and part of the image may be masked. It is a setting normally used 
for photo placements).

5) FIT CONTENT THEN FRAME PROPORTIONATELY

Fit Content then Frame Proportionally (newly-named for clarification) is a two-stage 
process. It starts by proportionally resizing the image to fit in the Element Image frame. 
After the image resizing, the frame size is adjusted to fit the content. (It is like using Fit 
Content Proportionally followed by Fit Frame to Content).

Expand From
This option allows project designers to automatically align imported graphics to any edge 
of an Element Image frame.

Select the side and corner of the image frame that will act as the reference points for any 
size change of the image. These are ‘frozen’ and the frame will resize from those points. 

Fitting set to ‘Fit Content then
Frame Proportionally’ and the
‘Expand From’ set to Top, Right. 

Step 1 Step 2 Step 3

‘Expand From Top Right’ example.
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For example (see screenshot) when fitting is set to Fit Content then Frame Proportionally, 
setting Expand From to Top | Right, causes the Bottom | Left corner of the image to resize 
to fit in the frame while keeping correct proportions, and then the frame resizes to match 
the new graphic size.

Setting Expand From to Middle causes the corners to move equally in opposite directions. 
For example, selecting Middle | Centre will cause the image or frame to shrink or grow 
precisely from the centre point of the image or frame.

Choosing Top, Middle or Bottom will cause horizontal resizing, and choosing Left, Centre 
or Right will cause vertical resizing.

Expansion Limit
The expansion limit sets the maximum scaling percentage allowed for an image during 
fitting to the Element Image frame. The minimum value is 100%. Select a preset expansion 
limit from the pop-up list, type your own percentage, or choose No Limit to ignore this 
option.

Reduction Limit
The reduction limit sets the minimum scaling percentage allowed for an image during 
placement in the Element Image frame. The maximum value is 100%. Select a preset 
reduction limit from the pop-up list, type your own percentage, or choose No Limit to 
bypass this option.

Element Content 
Element Content frames are placeholder text frames used within Typefi Elements. 

Note: Fields placed inside Element Content frames would be deleted during page-generation, and must 
therefore be placed inside normal InDesign Text Frames.

Creating an Element Content Frame
To create an Element Content frame:

 ■ Select the text frame with the selection tool.
 ■ From the Object menu select Typefi Frame Type > Element Content. 

(Alternatively, right-click the frame and select Typefi Frame Type > Element Content, or 
select Element Content from Typefi Element panel menu, Typefi Frame Type submenu).

To apply absolute height or width limits, for example 32mm 1.25 inch wide, 
use the Typefi AutoFit panel (see "Minimum and maximum object size" on 
page 13).

Bottom

Top

Left Centre Right

Middle

‘Expand From’ settings.
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The Element Content Frame Type has now been applied and can be distinguished by its 
thicker cyan frame edge.

Clearing Typefi Frame Type 
To clear a Typefi frame property from an InDesign frame:

 ■ Select the frame with the selection tool.
 ■ Choose Typefi Frame Type > None from the Object menu.

(Alternatively, right-click the frame and select Typefi Frame Type > None, or select None 
from Typefi Elements > Typefi Frames).

The caption in this element is an Element Content Frame 
with default border colour colour(cyan) showing
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Typefi Fields are content placeholders that carry values assigned by the 
author at the element, section or project level. The text that populates fields 
is automatically inserted into each instance of that field that appears in the 
InDesign document during page composition. 

Fields can exist on document title pages; as part of a running section header; or in a 
Typefi Element. When determining whether a field is relevant for usage in your InDesign 
template, look for text that repeats itself throughout a layout. For example, you can use 
them for chapter titles, chapter numbers, project names, dates, document references, 
author name, ISBN and so on. 

The following table provides some examples of Typefi Field uses:

Field Type Scope Sample uses Value supplied from

Project Field value can be 
used across all pages 
and sections in the 
current project.

Document title, author 
name, customer name, 
reference number, 
publication date, product 
name, part number

Project home page on 
Typefi Server
or
Inserted during Typefi 
Print… from Word.

Section Field value can be 
used across all pages 
in the current section.

Part title, chapter title, 
section number, component 
name

Section Insert in Typefi 
Writer

Element Element Fields for the 
inclusion of content in 
an element.

Captions, copyright data, 
figure number, date

Element Insert in Typefi 
Writer

Typefi Fields
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Project Fields
A Project Field is a field in which the value remains the same throughout all sections of a 
publishing project, regardless of the section in which it might appear.

Imagine you are working on a publishing project that is part of a series of publications. 
Each publication would have different titles, subtitles and author details. 

If you examine the title page design for the publication, several potential Project Fields 
can be identified:

 ■ Publication title - this text is repeated on the left page of the general content pages for the publication.
 ■ Publication subtitle - this field text doesn’t repeat, but in a series of publications, this content could be 

entered at project level, so that during running of the job this text is automatically inserted.
 ■ Publication author - this field also doesn’t repeat. However, in a series of publications, this content could 

be entered at project level similar to the Publication subtitle.
 ■ Publisher—this field could repeat on the copyright page.
 ■ Inside cover contains copyright information. The Copyright Year and Owner could be set as a Project 

Field. 

Create Project Field
To create a New Project Field:

 ■ Display the Window > Typefi > Fields panel
 ■ Select New Field from the panel menu (or click the New Field Definition icon at the bottom of the panel)

The Field Options dialog is displayed.

 ■ Enter a unique Name
 ■ Set the Type to Project
 ■ Click OK to create the new Project Field.

The Project Field is added to the Typefi Fields panel. In addition, any Project Fields that you 
add will appear as part of the Project Settings on the Typefi Server (see the Typefi Systems 
Server Guide).

Section Fields
While Project Field values remain the same throughout a publication (unless they are 
manually changed at Run Job level), Section Fields only retain their value throughout a 
single Typefi Section (see "Designing a Section" on page 16).

An example of a Title page design for a specific project

Creating a new Typefi Field, with a choice of two ways

Field Options dialog allows you to choose the type of field
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Section Fields, in addition to text, can include counters. Counters are useful for tracking 
chapter numbers, or could be used as a prefix for figure numbers that belong to a certain 
chapter number. Neither the value (number), nor the format (Arabic, Roman, etc.) of the 
counter can be defined within the content by the Author/editor. Instead, counters are 
automatically updated by the Typefi Designer plug-ins during page composition.

Note: When editing the published InDesign file post page-composition: Counters are updated 
automatically only when new Typefi Sections are inserted. Insertion of normal InDesign sections will 
not result in Counters being updated. This is because Section Fields are only associated with Typefi 
Sections. Regardless of the order in which Sections are published through Typefi Publish, Counter Fields 
will count sequentially, allowing shuffling of sections without having to renumber.

Examples of text that may be formatted using Section Fields include:

 ■ Chapter Number
 ■ Chapter Title (section fields can no longer be used for cross-references though)

In some cases chapters might form part of an InDesign ‘book’. Each part name or number 
could also be a Section Field.

Create Section Field
To create a new Section Field:

 ■ Display the Window > Typefi > Fields panel. 
 ■ Select New Field from the panel menu. 

(Alternatively, click the New Field Definition icon at the bottom of the panel).

The Typefi Field Options dialog is displayed.

 ■ Enter a unique Name.
 ■ Set the Type to Section.
 ■ Set the Format to either Text or Counter.
 ■ Click OK to create the new Section Field. 

Field Format settings define the field’s data type. Section Fields have their Format set to 
either Text or as a Counter. 

Text
Fields with Format set to ‘Text’ are filled with text by authors when creating a Section.

Section Fields and the choice of type and style

Creating a new Field—either click the button or choose from the menu

Field Options: Section Field with Format set to Text.
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To create a text-based Section Field:

 ■ Set Format to Text. 
 ■ Click OK to accept the setting and create the Section Field.

The New Section Field is added to the Typefi Fields panel.

Counter
Fields with Format set to Counter are populated with numbers automatically. The 
numbering mode is defined as part of the Typefi Section definition (see "Designing a 
Section" on page 16).

A Counter Field carries a numerical value that is incremented automatically as page-
composition inserts each Typefi Section. For example, consider a project job option 
set to publish a number of chapters that are each generated as an individual section 
in the publication. As each section is compiled, the chapter number is automatically 
incremented. If you opt to alter the order of sections at Run Job level, the numbering will 
adjust accordingly.

To create a Section Field that works as an automatic counter:

 ■ Select Counter as the Content Type for the Field. 
 ■ Click OK to accept the setting and create the Section Field.

The new Section Field is added to the Typefi Fields panel.

Note: Section Fields can also be defined as part of the Typefi Section (see "Typefi Sections" on page 16).

Element Fields
An Element Field is a Field that is used within a Typefi Element. In contrast to Section 
Fields, Element Fields do not support counters and are given a value during element 
insertion. The content author is prompted to enter a Field value when an Element 
containing Fields is inserted with the Typefi Writer in Word.

As the elements are inserted during the automated pagination the Element Fields are 
filled with the author-assigned values. 

Note: When including an Element Field as part of a Typefi Element, ensure 
that the Text Frame is a normal InDesign Text Frame and not a Typefi 
Element Content frame. Typefi Frame content is totally refreshed during 
the pagination process, thereby removing the field markers.

Setting Field Options for a Section Field with Format set to Counter.
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Create Element Field
To create a New Element Field:

 ■ Display the Window > Typefi > Fields panel. 
 ■ Select New Field from the panel menu. 

(Alternatively click the New Field Definition icon at the bottom of the panel).

The Typefi Field Options dialog is displayed.

 ■ Enter a unique Name.
 ■ Set the Type to Element.

The Format for Element Fields is automatically set to Text. 

 ■ Click OK to apply the settings and create the New Element Field.

The New Element Field is added to the Typefi Fields panel.

Note: Element Fields can also be defined when creating the Typefi Element (see "Assigning Element 
Fields to an Element" on page 52)

Applying Fields
Fields are always inserted in normal InDesign text frames and never in Typefi Frames, as 
any pre-existing content in Typefi Frame types is replaced by actual content during the 
page-composition process.

Apply Field with text highlight
When applying a field to highlighted text, the text becomes the default data value for this 
Field. 

To apply a field to highlighted text inside a text frame:

 ■ Highlight some text with the Type tool
 ■ Select the Field Name in the Typefi Fields panel
 ■ Select Apply Field from the panel’s menu or click Apply Selected Field at the bottom of the Typefi Fields 

panel

(Alternatively, double-click the Field Name to add Field Markers around the highlighted 
text).

Field Options: Element Field with Text as Content Type.

Applying the selected Field.

Create new Typefi Field (with the choice of two ways)
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Field Markers appear as red square brackets around the highlighted text and indicate that 
the Field Definition is applied to the text. If you opted to apply a field at the text cursor 
insertion point, without highlighting text, you will see the Field Name surrounded by Field 
Markers instead.

To display Field Markers:

 ■ Enable Show Field Markers option from the Typefi Fields panel menu.

During page composition the template text marked up with Project Field Markers is 
replaced by the assigned Project Field values. When publishing a job from the Typefi 
Server the field values are picked up from the Project Settings (see also ‘Starting a Project’ 
in Typefi Publish 6 - Server User Guide). When printing a job from Typefi Writer, the values 
are picked up from the values entered in the Typefi Print dialog (see also ‘Publishing from 
Word’ in Typefi Publish 6 - Server User Guide).

Apply Field without text highlight
To insert a field in a text frame without having existing text highlighted:

 ■ Place your cursor at the insertion point in the Text Frame
 ■ Select the Fieldname of the Field in the Typefi Fields panel
 ■ Select Apply Field from the panel’s menu. 

(Alternatively, double-click the Field name to add Field Markers around the highlighted 
text or click Apply Selected Field at the bottom of the Typefi Fields panel).

For example, let’s assume the Element design requires the author to enter the name of a 
painting, as well as the date and painter’s name. To prompt the author for data entry when 
the Element is inserted into the Word document with the Typefi Writer, you could assign 
three Element Fields as part of the Element definition. One Element Field is used for the 
name of the painting; a second field for the date; and a third for the painter’s name.

An InDesign Text Frame can contain multiple Fields as well as pre-defined text. The 
Element example here contains a Text Frame that not only fills two different Fields with 
text but also pre-populates the Text Frame with the words ‘Name’ and ‘Year’. When the 
author inserts the Element in Word using Typefi Writer a prompt will appear asking the 
author to assign values to ‘PaintingName’ and ‘PaintingYear’ fields.

Apply Element Field example.

Element with two Element Fields (left) and example of the result (right).

Typefi Fields applied.
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Field updating
When you change the content of any one Field, Typefi Designer updates all other 
instances of that Field throughout the document. You can use this feature to test how 
your document will react to certain Field values. Will a lengthy chapter title prove too long 
for the current page header design? If so, you can either redesign the page header or use 
AutoFit (see "AutoFit tool" on page 11) to adjust the frame as needed.

Updating Project Fields
When a Project Field value is amended in a text frame that is positioned on a Master 
page, the field value is updated on all other master pages on which it appears. However, 
if document pages contain ‘overridden’ (broken away from the master) text frames, the 
original project field values are retained.

Project Field values that reside within overridden text frames on document pages change 
globally across all document pages when their value is amended.

Updating Section Fields
Where a Section Field value is amended in a text frame that is positioned on a Master 
page, changes are applied only to occurrences of the Section Field within the Master 
Spread pages.

Section Field values (when changed within an ‘overridden’ text frame on a document 
page) only change on document pages that are part of the section to which the 
overridden text frame belongs.

When Section Counter fields are amended, a follow-on effect will occur in those Sections 
following it, as the counter values are set automatically.

Updating Element Fields
Element Field values that are changed are only updated within the Element to which they 
are applied. If the Element contains nested Elements, and the field repeats within these 
nested Elements, the nested Element field values update as well.
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Breaking Links to Fields
To break the link to a Field that has been applied:

 ■ Place your type cursor anywhere between the open and close Field Markers
 ■ Select Break Link to Field from the panel’s menu.

(Alternatively, click Break Link to Field at the bottom of the Typefi Fields panel).

The Field Markers are now no longer visible, indicating that the text is not marked up as a 
Field.

Renaming a Field
To rename a Field:

 ■ Select the Field from the Typefi Fields panel
 ■ Select Field Options… from the panel menu and change the Name
 ■ Click OK to acknowledge the name change.

(Alternatively, locate a text frame in your InDesign document that references the Field 
and place the type cursor anywhere between the Field Markers, then double-click the 
highlighted fieldname in the Typefi Fields panel to access Field Options… and change the 
name).

Each of these methods will update the Field name, but not the text that is listed between 
the Field Markers. To alter the text between the Field Markers you must edit it manually.

Deleting a Typefi Field
When a Typefi Field is deleted from the Typefi Field panel, the Field Markers throughout 
the template are removed. The text between the original field markers is then ‘normal’ 
text and therefore not affected by the removal of the field markers when the Typefi Field 
definition is removed.

To delete a Field from the Typefi Fields Panel:

 ■ Show the Typefi Fields panel (Window >Typefi menu)
 ■ Select the Field that is to be removed
 ■ Choose Delete Field from the panel menu

Break Link to Field.
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(Alternatively, click the Delete Selected Field icon at the bottom of the panel).

 ■ Click OK to go ahead and delete the Field.

The Field will no longer be listed in the Typefi Fields panel, and related Field Markers are 
removed from the document.
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Typefi Elements can be compared to assets stored in an InDesign Object 
Library. A Typefi Element—like a library asset—is created once, and then 
re-used throughout the InDesign layout with different content for each 
instance that is placed.

Elements work in conjunction with Typefi Frame Types (see "Typefi Frame types" on 
page 25) and (not in every case) Typefi AutoFit (see "AutoFit panel" on page 13) and 
can be formed from a single frame, or a group of frames, and can also include line or 
shape objects. In addition, Elements can contain Element Content or Image frames as well 
as Fields. 

There are three types of elements: Fixed, Inline and Floating Elements.

Fixed Elements
Fixed Elements are elements for which each instance appears in a predefined context 
and location. This is in contrast to Inline and Floating Elements which are placed and 
positioned based on their contextual relationship to content and layout rules during page 
composition.

The positioning and placement of Fixed Elements is based on their original master page 
position. The master page on which they are placed must be part of a Typefi Section 
(see "Designing a Section" on page 16). During page composition the content of this 
element is inserted and the Element position is based on its original position on the 
Master page. You can use only one instance of a particular Fixed Element per section.

Fixed Elements may also be used as a nested Element inside Fixed, Inline or Floating 
Elements (see "Nested Elements" on page 62). Fixed Elements also differ from Inline and 
Floating Elements in that they are not based on a prototype element.

Typefi Elements
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Inline Elements
Inline Elements compare best with InDesign’s inline or anchored objects. They are inserted 
into the main story text flow during page composition. The Inline position of these 
elements can be controlled by an External Paragraph Style (see "External Paragraph Style" 
on page 51) or anchored object options applied through an Object Style.

Floating Elements 
Floating Elements are designed objects that are placed outside the main content thread. 
The Typefi Engine places and positions them on a page according to layout rules and 
priorities. Floating Elements may use ‘variants’, which are layout design alternatives. They 
can be automatically selected during page-composition based on layout rules that you 
specify, or the design choice can be made by the author as the Element is inserted in 
the Word document. (Where Floating Elements overlap Text Frames, enable Text Wrap 
settings on the Element Group.)

The layout rules are only applied by the Typefi Engine during page composition. They are not 
considered if the user edits a document manually or if a script is applied. In other words, in contrast to 
all other features of the Typefi Designer, the Typefi Designer plug-in does not update floating element 
positions (neither automatically nor on demand).

Element creation process
Elements use various Typefi components such as Typefi Frame Types, Typefi AutoFit, Typefi 
Fields. Elements can also contain normal InDesign objects such as Text Frames, Graphic 
Frames or Lines. When creating a Typefi Element you could use the following steps as a 
‘best practice’ approach:

Step 1: Create the Element artwork in InDesign 

Step 2: Set AutoFit relationships and attributes

Step 3: Define Typefi Frames and Element Fields

Step 4: Apply Frame Types

Step 5: Define Elements and apply Fields

Step 6: Apply the defined Element to artwork

Step 7: Define Floating Elements, Variants and Layout Rules

Variants

Fixed Element

(with custom 
anchored object 

applied)

Float Element

Section
Master

Section Master

Non-Section
Master

Non-SectionMaster 4-5

2-3

2-3

2-3

1

Inline Element

Elements overview (simplified diagram).
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As an example of how you’d run through the element creation process, we’ll use the 
‘Painting Element’ that’s part of the da Vinci publication. This element is going to be a 
Floating Element.

Step 1: Create the artwork
Start by creating the artwork in InDesign, and then determine what type of element you 
will be creating: Inline, Fixed or Floating. The element you create is a prototype that Typefi 
uses throughout its page composition process whenever the element is inserted by the 
author in the content. 

Elements that appear more than once in a section, with different content in each element, 
are always either Inline or Floating. Each appearance of such an element throughout the 
paginated document is an occurrence of the Master Element, or an occurrence of the 
Master Element variant. Such elements cannot be Fixed, as only one occurrence of a Fixed 
Element can exist within a section.

Placement of elements
Although—in contrast to Fixed Elements—Inline and Floating Elements can be placed 
for use during page-composition on document pages in the InDesign template, it is good 
practice to keep the number of body pages in a template document to a minimum.

Therefore, as best practice, create your Inline and Floating Elements on separate 
master pages that are not used by Typefi Sections and create individual masters for 
each element type. Typefi Publish will use these elements as objects that it can draw 
from during the page composition process. To have more control over Floating Elements 
consider placing them on their own layer. Avoid placing Inline or Floating Elements in the 
Pasteboard area.

Tip: For more accurate placement of Floating Elements, position them on Master Pages that are based 
on pages used by sections, so that margin and column settings are retained.

Step 2: Setting AutoFit relationships and attributes
Next analyse the artwork and determine the AutoFit relationships and fitting attributes for 
the various objects that make up the Element. Use the AutoFit tool and AutoFit panel to 
set these relationships and fitting attributes (see "AutoFit tool" on page 11).

You should limit the template document to just one normal page 
with no content and the master page [None] applied to it. This is just a 
recommendation if performance matters, since the more body pages a 
template document contains, the more time it will take the Typefi Designer 
plug-in to open and clear those pages. 

Line 1, always same 
distance from top of image

Line 2, fixed distance from 
bottom of text frame

Text frame containing 
painting details.

Image of painting, must 
display full-painting, no
wider than current width,
but can size up or down.
Image must be placed
proportionately

Sample Element comprising multiple objects
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Let’s review the relationship and fitting requirements of the sample element again:

When the graphic frame is resized as a result of image sizing, the Line 1 must be moved 
with it, as it must retain a fixed distance to the top of the graphic frame. This is a parent-
child relationship between the top of the graphic frame and the line.

The text frame containing the caption must be repositioned as the bottom of the graphic 
frame is repositioned. This is a parent-child relationship between the bottom of the 
graphic frame and the top of the text frame.

The text frame itself must grow from the top down as more content is entered. This is an 
AutoFit attribute: Height Only.

As the bottom of the text frame grows to make text fit, the line below it must move. 
Therefore, there must be an additional parent-child relationship between the bottom of 
the text frame and Line 2.

We assume that the element has a fixed width, as it is going to appear as a marginal note. 
(You could consider setting a maximum width on the graphic frame that prevents it 
exceeding this margin width.)

Consider width and height requirements
Use frame height restrictions—such as maximum height—to ensure that an element 
cannot grow beyond a reasonable size. Minimum size settings could be handy when an 
author inserts an element, but has not yet received content for that particular element. 
A minimum size setting would ensure that a certain amount of space is reserved in the 
layout for the element during page composition.

Step 3: Typefi Frames and Element Fields
With the AutoFit relationships and fitting attributes set, it is time to determine which 
element items or components are going to be defined by Fields and which will become 
Typefi Frames. 

Consider the following:
1. Element Fields are generally used by the author for entry of data that is limited in 

length and would be inserted in normal InDesign Text Frames.
2. Fields inserted inside Element Content frames will always have their entire content 

overwritten, thereby clearing any literal and Field data that pre-existed in these frames.
3. The Element Content frame should be applied to the Text Frame that is to hold the 

majority of the element’s text, and can hold multiple paragraphs of text.

Set AutoFit Relationships and Attributes.
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4. An Element can only contain one ‘unthreaded’ Element Content frame. Where multiple 
Element Content frames are required, they must be threaded, then grouped. To use 
multiple Element Content frames within an Element, use nested Elements (see "Nested 
Elements" on page 62). Text frame threading must be retained within the element 
and may not thread to frames in other (nested) elements.

5. An Element can contain one or more Element Image frames. However, as the placement 
order for the images depends on the order in which the images were added to the 
Element Group, it is difficult for the Typefi Designer to control placement of images 
in intended order. An alternate solution would be to build a series of fixed elements 
containing element image frames and nest these inside the Element.

In our example we can use three Fields to set the detailed information for painting name, 
date and painter, as this data resides in a single Text Frame. If we were to use an Element 
Content Frame instead, then the author would have to remember in which order to type 
in these details, as all content must be provided by the author. In addition, the words ‘by’ 
in front of the painter’s name and ‘date’ in front of the year in which the painting was first 
finished must be included. The graphic frame would become an Element Image frame. 

Step 4: Apply Field(s) and Frame Types.
Set the Element Content and Image Frame Types. Then for the remainder of the text 
frames apply the Fields. (For more information about defining and applying Fields see 
"Typefi Fields" on page 36. For additional information on Frame Types see "Typefi Frame 
types" on page 25).

Step 5: Define Elements
In order to create an Master Element from the artwork you’ve created, you must first 
define the element itself. 

To define a new element:

 ■ Select New Typefi Element from the Typefi Elements panel menu. 

(Alternatively, click the New Element icon at the bottom of the Typefi Elements panel).

The New Typefi Element dialog box appears.

 ■ Set the Element Type to either Fixed, Floating or Inline
 ■ Enter the rest of the settings as appropriate
 ■ Click OK to save add the Element. 

The newly defined Element is now listed in the Typefi Elements panel.

Element with fields added to a text frame

Defining a new Element (with two choices)
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Defining a Fixed Element 
To define a Fixed Element:

 ■ Select New Typefi Element from the Typefi Elements panel menu (or click the New Element icon at the 
bottom of the Typefi Elements panel.

 ■ Enter a unique Element Name
 ■ Set the Element Type to Fixed
 ■ Set the Default Paragraph Style
 ■ Click Fields and Assign Element Fields that are to be used by the Element (see "Assigning Element Fields 

to an Element" on page 50)
 ■ Click OK to add the New Element to Typefi Elements.

DEFAULT PARAGRAPH STYLE 

The Default Paragraph Style is the paragraph style assigned to the Element Content area 
when the Element in question is inserted through Typefi Writer in Word and is therefore 
only meaningful in Typefi Publish processes that include Typefi Writer usage. 

The Default Paragraph Style applies to content paragraphs, and may be overridden with 
other styles if needed by the author using the Typefi Writer. 

If an Element Content frame is to contain lots of normal text paragraphs with the 
occasional subheading, you’d set the Default Paragraph Style to ‘Normal Text’ (or whatever 
the style is named), so that the author would only need to apply the ‘subheading’ styles 
for text that is different.

ASSIGNING ELEMENT FIELDS TO AN ELEMENT 

Any fields that are part of the Element must be included in the Element. For extensive 
information on Element Fields and insertion of Fields in Text Frames see page 39.

To assign Element Fields to an Element:

 ■ Click Fields in the Typefi Element Options dialog to display the Field section of the dialog.
 ■ Enable those Fields that must be used by the Element.

Alternatively, if the Element Field has not yet been defined:

 ■ Define a new Element Field by clicking the New Field icon.
 ■ Name the Field .

For all of the Fields assigned to the Element, the author is prompted to provide input data 
when inserting this element with Typefi Writer in Word.

Setting Fixed Element options.

Enabling Element Fields in Typefi Element Options.

The New Field button at the bottom of  the Fields panel
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Fields may be used to store hidden meta-data that does not appear in the final output, but is required 
for the content and the XML into which the content is ultimately transformed.

DELETING AN ELEMENT FIELD

The Field area in the Typefi Element Options can also be used to delete Element Fields. 
However, this only works for Element Fields you’ve just defined in Typefi Element Options. 
Fields added to the Elements Fields list whilst the Typefi Element Options dialog is open 
are listed in Italics when they are not selected, so that they can be distinguished from any 
Fields defined earlier.

If any other Element Fields need to be deleted please refer to "Deleting a Typefi Field" on 
page 43.

To delete a field:

 ■ Enable the field you’ve added earlier.
 ■ Click the Delete icon at the bottom of the Fields list.

Defining an Inline Element
To define a new Inline Element:

 ■ Select New Typefi Element from the Typefi Elements panel menu

(Alternatively, click the New Element icon at the bottom of the Typefi Elements panel).

 ■ Enter a unique Element Name.
 ■ Set the Element Type to Inline.
 ■ Set the Default Paragraph Style.
 ■ Set the External Paragraph Style.
 ■ Click Fields and Assign Element Fields that are to be used by the Element.
 ■ Click OK to add the Element to Typefi Elements.

DEFAULT PARAGRAPH STYLE

The Default Paragraph Style is the paragraph style assigned to the Element Content by 
Typefi Writer in Word (see "Default Paragraph Style" on page 50).

EXTERNAL PARAGRAPH STYLE

An Inline Element is usually placed within its own paragraph into the main story content 
during page composition in InDesign. (Like images, inline elements can appear within 
or outside a paragraph. The external paragraph style is therefore not applied if an inline 
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element is inserted within a paragraph). The External Paragraph Style assigns a paragraph 
style that formats this paragraph in which the Inline Element is placed.

You should create a unique paragraph style for Inline Element placement in InDesign 
(which would probably not be available to authors). The style would contain at least a 
setting for alignment and leading. Auto Leading adjusts the leading according to the 
height of the Element, thereby preventing it from overlapping text.

ASSIGNING ELEMENT FIELDS TO AN ELEMENT

Any fields that are part of the Element must be included in the Element. 

Defining a Floating Element
To define a Floating Element:

 ■ Select New Typefi Element from the Typefi Elements panel menu, or click the New Element icon at the 
bottom of the Typefi Elements panel.

 ■ Enter a unique Element Name. 
 ■ Set the Element Type to Floating. 
 ■ Select the Default Paragraph Style.
 ■ Enable Keep floats in order if required.
 ■ Click Fields and Assign Element Fields that are to be used by the Element.
 ■ Click OK to add the Element to Typefi Elements.

DEFAULT PARAGRAPH STYLE

The Default Paragraph Style is the paragraph style used by Typefi Writer in Word (see 
"Default Paragraph Style" on page 50)

KEEP FLOATS IN ORDER

Keep floats in order ensures that the order of appearance of Floating Elements is retained 
during page composition. Disabling the option means that the Typefi Engine is free to 
change the order of the Floating Elements during pagination, if this provides a better 
placement option.

ASSIGNING ELEMENT FIELDS TO AN ELEMENT 

Any fields that are part of the Element must be defined as part of the Typefi Element (See 
"Assigning Element Fields to an Element" on page 50).

In the example above, we’re defining the Floating Element for PaintingDetails. The three 
Element Fields added earlier must all be listed in the Used Fields list, so that the author will 
be prompted to enter the specific information requested by each of the Fields, e.g. Name 

Inline Element – Typefi Element Options.

Defining a Floating Element.

Assigning Element Fields to the Typefi Element.
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of the Painting (PaintingName), Date of the painting (PaintingDate) and the Name of the 
painter (PaintingBy). 

Element listing
All Elements are listed in the Elements panel. Each element type is preceded by an 
element specific icon. To display all Element Types in the Elements panel, select All from 
the Element Type pop-up menu.

For projects containing a large amount of elements, you might want to view only 
elements of one particular type. From the Element Type pop-up menu select the Element 
Types (Inline, Fixed, Floating) you’d to like display in the Elements panel.

Step 6: Apply the element.
At this stage we’ve prepared all of the artwork and defined a new Typefi Element. We have 
not yet defined the artwork itself as an Master Element. Applying the Element to selected 
artwork defines the Master Element.

Automatically Group Selections
Artwork that is going to have an Element applied to it must be grouped. However, you 
won’t need to manually group the objects before applying the Element. Simply enabling 
the Automatically Group Selections option in the Typefi Elements panel menu will do.

To apply a defined element to your artwork, whether it is a Fixed, Inline or Floating 
Element:

 ■ Select all of the frames and lines that make up the element with the Selection tool
 ■ Verify that the Automatically Group Selections option is enabled in the Typefi Elements panel menu
 ■ Select the Element Name from the Typefi Elements panel. If you can’t see the Element name, ensure 

that the Element Type menu lists All elements
 ■ Select Apply Element from the panel menu, or click Apply Selected Element at the bottom of the panel.
 ■ A default Light Blue coloured border appears around the group for Floating or Inline Elements, with a 

name tag in the lower left hand corner. Fixed Elements display a default Green border.

Master Element
Element designs for Inline and Floating Elements must be Master Elements in order for 
them to be useable by Typefi Publish during page-composition. 

Floating

Inline

Fixed

Different Element Types.

Applying a Fixed Element to a selected group of objects.
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The default Master Element Typefi Border colour is Light Blue. Disabling the Master 
Element option from the Typefi Elements menu turns the Element into an instance of an 
Element. The default Element Instance Typefi Border colour is Green.

Master Element and Instance Typefi Border colours could appear differently for 
documents with alternate Typefi Border Preference settings (see "Typefi Borders" on 
page 88).

Apply Fixed Element
An example of a Fixed Element would be a graphic that appears on the Chapter Title page:

To apply a Fixed Element:

 ■ Select all objects that form part of the Element design
 ■ Select the Element in the Typefi Elements panel
 ■ Choose Apply Element from the panel menu, or click Apply Selected Element at the bottom of the panel.

The green border indicates you’ve created a Fixed Element Instance. 

Apply Inline Element
To apply an Inline Element:

 ■ Select all objects that form part of the Element design
 ■ Select the Element in the Typefi Elements panel
 ■ Choose Apply Element from the panel menu, or click Apply Selected Element at the bottom of the panel.

A blue group border indicates the Inline Elements is applied to the artwork and the 
artwork is marked up as the Master Element. 

After applying the element to the artwork, consider applying an Object Style to the 
element that sets specific anchored object settings that position the Inline Element during 
page composition. 

Note: As Typefi places content dynamically, please ensure that the ‘Prevent Manual Positioning’ option 
in the Anchored Object Options is disabled when applying an Object Style to Inline Elements.

Apply Floating Element
To apply a Floating Element:

 ■ Select all objects that form part of the Element design
 ■ Select the Element in the Typefi Elements panel
 ■ Choose Apply Element from the panel menu, or click Apply Selected Element at the bottom of the panel.

Inline Element applied.

Floating Element applied.
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The default blue group border indicates the Floating Elements is applied to the artwork. 
As a Floating Element must have at least one variant, a single variant is listed immediately 
below the Element, with a [1] marker next to it, indicating that this is Floating Element 
Variant 1. 

The default Light Blue group border further indicates that the selected variant is marked 
up as the Master Element. Disabling the Marked as Master Element option from the Typefi 
Elements panel menu (only possible if there is another Instance of the Element) turns the 
Element into an instance of the selected variant. The default group border colour changes 
to Green.

As Floating Elements are often placed over the Main Story content, applying Text Wrap to 
them will ensure that the content of the Main Story flows around the elements. (To apply 
consistent and easily changeable Text Wrap settings to Floating Elements you could create 
and apply an Object Style to the element that only sets the Text Wrap settings to the 
element.) 

Step 7: Define Floating Element Variants and Layout Rules 
Floating Elements differ from Inline Elements as their Master Elements are always 
variants. Each variant has its own set of layout rules controlling variant selection and 
placement during page composition. An Inline Element, in contrast, has only one Master 
Element that must exist for pagination.

Floating Element Variants
Variants represent a design for a Floating Element. Every Floating Element must have 
at least one variant, but may also have more than one variant. Variants can be used to 
create asymmetrical versions of the same element (for example, one element design may 
be targeted at a left-hand page, and another at the right-hand page).

Variants can also be used to define different horizontal span sizes for elements (for 
example, one variant may span both columns in a two-column design, while another 
variant of the same element fits neatly into a single column).

Positioning of variants is controlled through layout rules. The layout engine will choose 
and place the variants based on these rules. Authors could limit that choice further, by 
specifying that a particular variant should be used as they are inserting the element in 
content. This also permits variants to be defined and used for special purposes such as for 
reserving the right amount of space on the page for an illustration that is still to come (for 
example, one variant could reserve a full page, while another could reserve half a page).

A variant must have a name in order for the author to be able to select it in 
the Writer.
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Creating Variants for Floating Elements
A variant is automatically created when you first apply a Floating Element to selected 
artwork (see "Apply Floating Element" on page 54).

To create additional variants for a Floating Element:

 ■ Select alternate element design artwork (such as a frame with caption)
 ■ Click the particular Floating Element name in the Typefi Elements panel
 ■ Choose Apply Element from the Typefi Elements panel menu, or click Apply Selected Element button at 

the bottom of the Typefi Elements panel.

Variants are automatically numbered [1], [2], etc., and during page composition every 
variant prototype is considered for placement. 

VARIANT OPTIONS

Variant Options set variant-specific settings such as: variant name, layer in which the 
variant is placed during pagination, and minimum space allowed between variants.

To edit the Typefi Element Variant options:

 ■ Select Element Options from the Typefi Elements panel menu

(Alternatively, double-click the variant in the Typefi Elements panel).

The Typefi Element Variant Options dialog is displayed (see screenshot)

 ■ Enter the Variant Name (if needed)

A variant name will be visible to the author in Typefi Writer and allow them to choose 
which variant is to be used during page composition. Leaving the Variant Name empty 
will not provide the author with the choice of variant, and consequently, the choice of 
variant is made by the Typefi Engine during page composition.

Different variants of an element can carry the same name (for instance, if there are right 
and left page versions of a Floating Element). Creating two variants with the same name, 
one for the left and one for the right hand page designs, will force the Typefi Engine to use 
the appropriate design when the element in inserted on either left or right hand page.

Variants that contain significant difference in appearance or layout rules should be given 
different variant names so that the author can easily identify them when inserting an 
Element and choosing a variant. 

 ■ Select the Layer in which the variant should appear

By default the layer in which the current variant is placed is selected. 

A Variant (named Margin_Float) of a Floating 
Element named PaintingDetail
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 ■ Set Float Spacing

To prevent multiple Floating Elements placed on individual pages from overlapping, 
enable Float Spacing for the element variant and set the minimum space settings. These 
space settings are used during page composition.

 ■ Click OK to apply the Variant Options to the selected Variant.

Setting Layout Rules
Each variant has its own set of Layout Rules. These layout rules are used by the layout 
engine during page composition and play an important role in determining where a 
Floating Element will be placed on a page.

To display a variant’s Layout Rules:

 ■ Select the variant in the Typefi Elements panel
 ■ The Layout Rules display in the lower half of the panel (you may need to extend the panel vertically and 

drag the divider down to reveal them)

Layout Rules for variants consist of three different rule components (see screenshot):
1) Align with… rule options that set rules for vertical and horizontal placement of the 

element
2) Priority bars, that the layout engine uses to prioritise the four Align with… rule settings 

when placing elements
3) Can appear on… settings that define whether an element can be placed on Left, Right 

or both pages during page composition

ALIGN WITH… RULE OPTIONS

Align with … rule options determine the vertical and horizontal positioning of variants 
during page composition. 

To define the Rule Options:

 ■ Click one of the dark grey Align With… bars in the Layout Rules section of the Typefi Elements panel

There are four Align with… rule options that can be set for a variant, namely:
1) Align with top of …
2) Align with middle of …
3) Align with bottom of …
4) Align with … of anchor

Note: If you move the Master Element of a floating element to a different 
layer in InDesign, this setting will be modified as well, moving also all 
element instances to that layer.

Layout Rules for selected variant, with cursor setting 
priority rules for variant alignment.

Rule Options (Align With … ).
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The first three rule options: Align with top, Align with middle and Align with bottom point 
to vertical positioning in relation to the Text Frame position (Main Story Frame) by default. 
The fourth rule is set to Align with Baseline of anchor by default.

VERTICAL ALIGNMENT

Vertical Alignment settings determine the vertical positioning (top/bottom) of the 
Floating Element variant on the page.

The Align with Top, Middle and Bottom of … rule options define:
a) Which part of the Floating Element Variant (Top, Middle or Bottom) is going to align to 

the Top of either Column Edge, Text Frame (default), Page Margin, Page Edge or Master 
Element.

b) Which part of the Floating Element Variant (Top, Middle or Bottom) is going to align 
to the Middle of either Column Edge, Text Frame (default), Page Margin, Page Edge or 
Master Element.

c) Which part of the Floating Element Variant (Top, Middle or Bottom) is going to align 
to the Bottom of either Column Edge, Text Frame (default), Page Margin, Page Edge or 
Master Element.

As an element is inserted in content using Typefi Writer a link is defined between the 
element and the text position where it was referenced in the text. After page composition, 
these links can be made visible in InDesign. The markers that display the link are called 
Typefi Anchors.

To display Typefi Anchors in InDesign:

 ■ Select Show Typefi Anchors from the View Menu.

The Align with… of anchor option defines which part of the Floating Element Variant (Top, 
Middle or Bottom) is going to align to either the Baseline, Cap Height, Top of Leading, or 
Top of Paragraph of the anchor position. The anchor position relates to the point at which 
an author inserts an element into the Word document.

The following table summarises the anchor-based vertical alignment options.

Option Description

Baseline Positions the top, middle or bottom of float to the baseline of the Anchor 
location for the element.

Cap Height Positions the top, middle or bottom of float to the Capital Height of the line of 
text in which the anchor is placed.

Vertical Alignment example: Top of float aligned with Baseline of anchor.

Vertical Alignment example: Top of float aligned 
with Top of Paragraph of anchor.

Vertical Alignment: Top of float to Top of Leading of anchor.
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Option Description

Top of Leading Positions the top, middle or bottom of float to the Top of the Leading of the 
line of text in which the anchor is placed. This means that the top, middle or 
bottom of the float is seemingly aligned with the bottom of the previous line.

Top of Paragraph Positions the top, middle or bottom of float to the top of the paragraph 
in which the anchor is placed. If the anchor is placed at the end of the 
paragraph, the alignment will relate to the top of the first line of that 
paragraph.

When an Align with… option is edited, the Layout Rules text display for the option in the 
Typefi Elements panel is updated. 

For instance, let’s look at the default Align with top of Text Frame rule option. If we change 
this to Align Top of float to Top of Page Edge, the rule text will change to top of page edge.

The Y-offset value defines a further vertical movement for the element after placement 
according to the Align with… rule options. A negative value will move the element up; a 
positive value will move the element down. The value (-3mm) assigned for the Y-offset in 
the previous Rule Options screenshot, moves the element outside the page area into the 
document bleed.

The Top and Bottom Limit options further constrain the positioning of the variant 
vertically. Keep in mind that these options carry the highest level of priority and overrule 
other Vertical Alignment settings. For instance, setting the Top Limit to Page Edge and 
entering a negative Y-offset value (-3mm) in the example above will push the Element 
-3mm into the bleed area of the document. The Top Page Edge value (equal 0mm), would 
override the negative Y-offset value. 

Vertical 
Alignment Limit 
Options

Description

No Limit Variant placement can fall inside as well as outside the page boundaries. 
Where No Limit is selected, the Y-offset and Align with… options will take 
precedence.

Column Edge Variant placement must fall within the top and bottom edge of the text 
column position frame on the page. This will be the text column that 
contains the Typefi Anchor to the variant.

Text Frame Variant placement must fall within the top and bottom edge of the Text 
Frame on the page. This will be the main story frame.

Page Margin Variant placement must fall within the top and bottom margins defined for 
the page on which it is placed.

Rule Options for Align with Top of … settings.

Edited Align with… rule.
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Vertical 
Alignment Limit 
Options

Description

Page Edge Variant placement must fall within the top and bottom edge of the page.

Master Element Variant placement must fall within the top and bottom position of the actual 
Master Element. Setting these limits to Master Element ensures vertical 
positioning is set to the current prototype variant position.

HORIZONTAL ALIGNMENT

Horizontal Alignment options define the horizontal positioning (left/right) of the variant 
on the page.

The Align with… rule options define:
a) Which part of the Floating Element Variant (Left, Centre, Right, Outside, Inside) is going 

to align to the Left, Centre, Right, Inside, Outside of either Column Edge, Text Frame, 
Page Margin, Page Edge or Master Element (default).

b) Which part of the Floating Element Variant (Left, Centre, Right, Outside, Inside) is going 
to align to the Anchor

Inside/Outside settings refer only to the documents with facing pages (left/right-spreads). 
 ■ Inside refers to the spine-side.
 ■ Outside refers to the trim-side. 

The use of Inside/Outside alignment options allows a single variant to be used on both 
Left and Right pages.

The X-offset value defines a further horizontal movement for the element after placement 
according to the Align with rule… options. A negative value moves the element to the left; 
a positive value moves the element to the right.

The Left and Right Limit, determine the outermost positions at which the variant may be 
placed in the page composition.

Horizontal Left / 
Right Limit Setting

Description

No Limit Variant placement can fall inside as well as outside the page boundaries. 
Where No Limit is selected, the X-offset and Align with… options will take 
precedence.

Column Edge Variant placement must fall within the left/right edge of the text column 
position frame on the page. This will be the text column that contains the 
Typefi Anchor for the variant.

Horizontal Alignment Options.

Element variant placement in double-sided layouts
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Horizontal Left / 
Right Limit Setting

Description

Text Frame Variant placement must fall within the left/right edge of the Text Frame on 
the page. This will be the main story frame.

Page Margin Variant placement must fall within the left/right margins defined for the 
page on which it is placed.

Page Edge Variant placement must fall within the left/right edge of the page.

Master Element Variant placement must fall within the left/right position of the actual 
Master Element. Setting these limits to Master Element ensures horizontal 
positioning is set to the current prototype variant position.

PRIORITY BARS

Each Align with… rule has its own priority bar. The Priority Bars set the importance level 
of the rule. Priorities can range from none (0), to some (1, 2, 3), to full (4).

To edit the priority level for an Align with… rule:

 ■ Click on the bars with the mouse. 

Clicking to the left of the smallest bar sets the priority level to none. 

During page composition, the Typefi Engine considers all rules and priority levels set for 
the variants. It then determines the best possible layout through placement of elements 
according to the highest combined priority levels. When one Align with… rule has a 
priority setting and others don’t, the Typefi Engine will use the priority setting and 
matching Align with… rules for placement of the element variant. 

For example, to align an element to the top of the page and never any other position, set 
the align top of frame rule to the highest priority and set the priority level to none for all 
other Align with… rules.

Overall, variants with a higher overall priority setting will take precedence on the page 
during page composition.

CAN APPEAR ON… OPTIONS

The Can appear on left or right page options define whether a variant may be placed on 
a left page, right page or both left and right pages. Select Can appear on … text, to allow 
placement. Deselect Can appear on … text, to disallow placement.

Priority Bars indicating rule preferences

Choosing whether an Element can appear on 
left or right-hand pages (or both)
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More on Fixed Elements
The same Fixed Element can be applied to artwork on different Master Pages used as part 
of a Typefi Section definition. However, content for an individual fixed element is only 
assigned once per section. This means that where an Element is repeated on other master 
pages, the same content is inserted for each occurrence of the Element.

Therefore, you should use Fixed Elements on the Master Page that starts a section (or any 
master used only once per section), rather than on the repeating pages.

Be consistent in usage of Typefi frame types for Fixed Elements, especially where they are applied to 
different artwork on various Master Pages that are part of sections. In addition, you should refrain 
from using Fixed Elements of the same name more than once, as different pagination results could be 
generated in different versions of Typefi Publish.

Nested Elements
Fixed Elements may be nested inside Fixed, Floating or Inline Elements. An example would 
be a Floating or Inline Element that consists of three graphic+caption components.

Each of these sub-components could be defined as an individual Fixed Element and 
included in the Floating or Inline Element. The Floating or Inline Element must contain 
an Element Content frame (set to be non-printing and made very small) in order to 
populate this with the Fixed Elements it contains. Using this technique makes it easier 
to provide prompts for authors in regards to insertion of multiple images or fields in an 
element.

Fixed Element placed on different pages.

nested

Element Content Frame

Three Fixed Elements nested within a Floating Element, 
and an Element Content frame to hold them in place
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Anchors are markers that indicate where an element is referenced in the 
content. The location of the element in relation to its anchor is determined 
by the element’s layout rules.

Displaying Anchors
In a paginated InDesign document that contains placed elements, the relationship 
between an element and its reference point in the text can be displayed by selecting 
View > Show Typefi Anchors when in ‘Normal’ view (as with frames and text frame links, 
they are not visible in ‘Preview’ mode).

When displaying a story that contains Typefi Anchors in the Story Editor (Edit menu), 
anchors are displayed using the same icon InDesign uses to display Anchored Objects.

For Fixed and Floating Elements, the Story Editor will display a single Anchor icon. For 
Inline Elements, the Story Editor displays two Anchor icons. The first of these is the Typefi 
Anchor and the second is the InDesign anchor. Deleting the first anchor will leave the 
Element artwork in place, but it loses its reference to Typefi. Deleting the second anchor 
will result in total deletion of the Element and both anchors will be deleted.

Repositioning Anchors
To edit the Anchor position:

 ■ Start by displaying the Typefi Anchors
 ■ Place your text cursor close to the anchor position in the text
 ■ From the Edit menu select Edit in Story Editor (The Story Editor window appears)
 ■ Locate the anchor or anchors and highlight them. 
 ■ Place the cursor in the highlighted area and when the drag and drop text icon appears, click and drag 

the highlighted anchor(s) to their new position.

Typefi Anchors

Floating Element with Anchor relationship displayed.

Inline Element with double Anchor displayed in the Story Editor.
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Drag and Drop Text Editing for the Story Editor must be enabled in Preferences > Type in order to drag 
and drop anchors into new positions (which it is by default).

Creating Typefi Anchors
When a new Element instance is added to an InDesign document post-pagination, a Typefi 
Anchor is not automatically inserted. 

Note: Anchors created for Inline Elements are inserted next to the InDesign anchored object anchor.

To create Typefi Anchors after placement of new Elements:

 ■ Go to Object > Typefi Element Anchors
 ■ Select the Create At Start of Page or Create At End of Page command

Anchors will be created for all Elements that lack a reference.

Create At Start of Page
Create At Start of Page inserts the Anchors at the start of the first paragraph on the page 
that contains the Element. If this paragraph starts on the previous page, the anchor is 
actually inserted at the end of the previous page. 

Create At End of Page
Create At End of Page inserts the Anchors at the start of the last paragraph on the page 
that contains the Element. If this paragraph continues on the next page the anchor is 
actually inserted at the start of the next page.

To move an anchor to a different location after creation, use the steps outlined in 
"Repositioning Anchors" on page 63.

Remove all Anchors
When performing a lot of post-processing editing tasks in InDesign, such as moving 
elements to different pages or locations, it might be useful to remove all anchors prior to 
(re)creating them.

Anchor position changed.
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To remove all anchors:

 ■ Go to Object > Typefi Element Anchors
 ■ Select Remove all Anchors
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In contrast to earlier versions, there is no need to create prototype Typefi 
tables in version 6. Control of table width has reverted to the author using 
Typefi Writer in Word. All a publication designer needs to do is create the 
table styles needed. An InDesign Table Style prescribes how a table is to 
be formatted. When you define a table style and apply it to many tables, 
each table is formatted exactly the same as the others. As you edit the table 
style, any tables formatted with the style will automatically be updated 
throughout the document. (Cell Styles are available in an XML workflow.)

Table Styles include specific properties—such as table formatting and column width 
behaviour—that is used during the Typefi process. All of the Table Style settings assist the 
layout engine in working out which formatting it should apply to the various rows and 
columns of the table.

Table Styles must be added to the InDesign template so that the author can use them in 
Word. These tables, once marked-up appropriately with Typefi Writer, will then reformat 
themselves during page composition in accordance with the Typefi Table Style settings.

Creating Table Styles
You can create Table Styles from a base table style design created using InDesign’s built-
in Table Styles, Cell Styles, and Table feature, and then further formatted to the design 
requirements. 

In contrast to how Elements work, Table Styles are fully self-contained and don’t require 
the original table to be kept, similar to the way paragraph, character and object styles 
work. For example, once you’ve created a new Table Style—which could be based on 

Table Styles
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a table style you’d started with—the original table is no longer required for formatting 
purposes. 

Insert Table
To insert a new table, ensure you have created a text frame first and inserted the Type 
Cursor at the table insertion point. To insert a new table select Table > Insert Table. The 
Table Dimensions dialog appears, prompting you to enter header, footer, body rows and 
columns settings. To create a new table that is not based on an existing Table Style, ensure 
the Table Style option is set to [No Table Style].

Enter at least the minimum rows and columns settings required to create a table that can 
contain all table attributes.

Row Types
Header Rows are rows located at the top of the table and can repeat themselves when a 
table breaks across columns, frames or pages during pagination. Footer Rows are rows 
located at the bottom of the table and can repeat themselves when a table breaks across 
columns, frames or pages during pagination. 

Format table
You’re now ready to continue formatting the table. Start by using InDesign’s Table Options 
and Cell Options to define Table Setup, Alternating Row/Column Stroke or Fill Settings, 
Text Inset, Row Height etc. and format the header rows, footer rows and body cells with 
paragraph styles. In addition, create InDesign Cell Styles to allow custom formatting of 
header rows.

InDesign’s Table Styles are limited, applying just one cell style for the formatting of Header Rows or 
Footer Rows. In addition, InDesign can only define a different layout for one Left and one Right column. 
There is a Typefi module called Enhanced Table Formatting, which addresses these shortcomings.

New Table Style
Once you’ve created and formatted the table in InDesign you are ready to create a new 
Table Style.

Insert table using InDesign native table dialog

Example of table containing two Header Rows, two 
Header Columns and one Footer Row.

Table fully formatted.
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To create a new Table Style:

 ■ Select the entire table.
 ■ From the Table Styles panel menu select New Table Style or alternatively click the New Table Style icon.

The New Table Style dialog box appears.

 ■ Enter a unique Table Style Name for the style you are creating. 

This table style name will be available to the author as a table is inserted in content using 
Typefi Writer. 

 ■ Make the appropriate table attribute changes where required for each of the categories listed in the 
dialog: General, Table Setup, Row Strokes, Column Strokes, Fills, Headers and Footers. 

 ■ Click OK to add the Table Style to the Table Styles panel.

Creating a new table style from a table style that is already formatted in InDesign 
automatically copies across the Table Setup, Row/Column Strokes, Fills and Header and 
Footer settings.

Mark as Master Table
The InDesign Table menu contains an additional Typefi Publish-specific item: Typefi Table 
> Mark As Master Table

‘Mark as Master Table’ explicitly indicates the table in the template that should be used as 
the basis for new table instances.

New Table Style dialog, with choice of Cell Styles 
for Header Rows and Left Column
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Cross-references are textual references within a publication that direct 
the reader to source text located elsewhere in the same publication. An 
example of a cross-reference would be (see “xxx” on page x), a source 
reference that refers to a heading and/or page number the reader may read 
for additional information. The production designer chooses or creates the 
various cross-reference formats that will be available to the authors using 
Typefi Writer in Microsoft Word. Cross-references may be added to the 
InDesign output file in the post-production phase.

You cannot make a cross-reference to a project or section field in Typefi Publish 6—this is due to the 
fact that the Typefi process now uses InDesign’s native cross-references and formatting (which allows 
custom formats). Since ‘project fields’ and ‘section fields’ do not exist in normal InDesign documents, 
there can be no cross-references to them. Such cross-references in legacy documents will have to be 
modified or removed, and all others checked for type of format. There is no need for a separate page 
number cross-ref, and such redundant page number cross-refs should be deleted.

Cross-references of various types and formats may be inserted by an author using Typefi 
Writer and appear fully formatted in the paginated InDesign document. They can also be 
inserted or edited post-pagination in the InDesign document. 

Cross-References
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Post-Production Cross-referencing
InDesign allows for easy editing and creation of cross-references based on selection of 
cross-reference sources that point to the following categories:

 ■ Paragraph: text formatted using a selected paragraph style, such as a Heading, Caption etc. The cross-
reference actually points to the start of a selected paragraph formatted with the selected Paragraph 
Style.

 ■ Text Anchor: references pointing to Text Anchors created using the Hyperlink Destination choice in the 
Hyperlink panel menu. 

Do not use InDesign ‘Bookmarks’ as the source for a cross-reference—they are alphanumeric text 
strings that make no sense.

Inserting a Cross-reference
A cross-reference uses source text (including or excluding automatic numbering), anchor 
name, paragraph numbers, or page number details from the selected cross-reference 
source. Cross-references inserted in InDesign can point to any currently open document. 
The active document is the root of the cross-reference source.

To insert a new cross-reference place the text cursor at the cross-reference insertion point:

 ■ Select Hyperlinks & Cross-References > Insert Cross-Reference… from the Type menu. 

The InDesign New Cross-Reference dialog box is displayed.

 ■ Choose Paragraph in the Link To area (circled in screenshot)
 ■ Select the paragraph style with which the source content is formatted (circled in screenshot)
 ■ Select the particular heading to which you are making the cross-reference from the list that appears
 ■ Set the Cross-Reference Format to the most suitable one (or make a custom one)

These are the formats available by default:

Format Name Explanation

Full Paragraph & Page Number insert the text of the entire paragraph (usually a few 
words only, such as headings), including the page 
number, as the cross-reference (for EPUB, this should 
be edited to not include the page number)

Full Paragraph copy just the text of the entire paragraph

Paragraph Number & Page Number insert the number of the paragraph (such as a 
numbered heading), and the page number as the 
cross-reference

A Hyperlink Destination that will be suitable for 
a cross-reference to a Text Anchor

Insertion of paragraph cross-reference.
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Format Name Explanation

Paragraph Number use just the number of the heading as the cross-
reference

Text Anchor Name use the name you created as a text anchor as the 
cross-reference

Text Anchor Name & Page Number the above plus page number

Page Number use just the page number as the cross-reference (for 
EPUB, this would have to be modified)

[your custom format] [create using building blocks provided]

Here is an example of a customised cross-reference format:

(See <cs name=”Bold”></cs>”<fullPara />” <cs name=”[None]”></cs>on <cs 
name=”Bold”></cs>page <pageNum />)

This would appear as:

(See “Typefi Sections” on page 6) 

Text Anchors
To insert a cross-reference that points to an InDesign text anchor, you must first ensure 
that you have created some InDesign text anchors using the Hyperlink Destination (see 
"Typefi Hyperlinks" on page 88. 

 ■ Choose Text Anchor from the Link To drop-down menu (circled in screenshot)
 ■ Select the relevant Text Anchor from the pop-up menu (circled in screenshot)

In the example shown the cross-reference will point to the ‘AutoFit’ Text Anchor. The Text 
Anchor list will display the names of all available InDesign text anchors. 

 ■ Select the appropriate cross-reference format from the Format list (see table above).

InDesign Bookmarks and Hyperlinks
The best results for a cross-reference to text other than a heading is to create a Hyperlink 
Destination.

To create an InDesign text anchor:

 ■ Select Window > Interactive > Hyperlinks panel
 ■ Highlight the source text and select New Hyperlink Destination from the panel menu 
 ■ Choose Text Anchor in the following dialog
 ■ Modify the name if necessary

In this instance, ‘<cs name=“Bold”></cs>’ is the instruction to apply a 
character style called ‘Bold’ to the text that follows, up to the close tag. For 
more information about cross-reference formats etc., read InDesign/Cross-
references in Adobe Online Help.

Insertion of text anchor cross-reference.

InDesign Bookmarks panel.

http://help.adobe.com/en_US/indesign/cs/using/WS9AD9A0DA-E10F-4d1e-9EB2-999FB61D21E8.html
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 ■ Click OK. 

The Text Anchor is created and is now available as a cross-reference source.

Hyperlinks
When cross-references are set to create a hyperlink, InDesign hyperlinks are used. 
However, post-editing in InDesign might see the requirement to insert additional InDesign 
hyperlinks, such as URL links. 

For more detailed information on InDesign bookmarks and hyperlinks please refer to 
InDesign Help. 

Word Hyperlinks: Word documents containing native Word hyperlinks for web and email addresses 
are automatically converted to InDesign hyperlinks during page composition. To format these types of 
hyperlinks differently, add a Hyperlink character style to the InDesign template, and apply the style to 
the hyperlinked text.

Update Cross-reference
To update a cross-reference (only possible if either the source or the cross-reference itself 
have been modified):

 ■ Insert the text cursor anywhere in the cross-reference text
 ■ Select Hyperlinks & Cross-references > Update Cross-Reference from the Type menu. 

The selected cross-reference is now updated.

Choosing the Type of Hyperlink Destination 
and the name for the Text Anchor
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Footnotes are generally notes that have a reference in the text that are 
placed at the bottom of a page (in contrast to endnotes, which generally are 
placed at the end of a document).

Footnotes
Footnotes are used to add some additional information about something referred to in 
the main text and are generally numbered in-text and then referenced by that number at 
the bottom of the page.

In Typefi Publish, footnotes appear at the bottom of the Main Story text frame during page 
composition (except in EPUB production, in which the footnotes appear as endnotes).

Typefi Publish has support for both Word and InDesign footnotes:

Word Footnotes
Footnotes inserted in Microsoft Word are passed through to the paginated InDesign 
documents and are formatted using the InDesign template settings under Type > 
Document Footnote Options… This means that none of the Word footnote settings will be 
retained. 

Note: Although Word supports the use of footnotes inside tables, InDesign does not, which means that 
such footnotes are ignored by the Typefi Engine and consequently won’t appear.

When a footnote is inserted in Word, Word automatically generates a Footnote Reference 
and Hyperlink character style. The footnote reference style in Word formats the reference 
number in the text. As best practice, you might want to add similarly-named character 

Footnotes and Endnotes

A footnote in InDesign appearing at the bottom of the Main Story frame
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styles to the InDesign template. (Use all lower-case, e.g. ‘footnote reference’ due to 
renaming of styles in RTF format.)

There is an important setting in the Document Footnote Options concerning the Footnote 
Reference Number. It is important to set the Character Style to [None] (see screenshot), 
otherwise the formatting of the footnote reference number will continue to the end of the 
paragraph (or another character style).

The footnotes themselves in Word are formatted using the Footnote Text paragraph style. 
You should create a similarly named (use lower-case only) style in InDesign for use in 
defining the Document Footnote Options...

In addition, Word supports continuous footnote numbering across sections. InDesign 
only supports numbering across a section, spread or page. This means that for a Word 
document that contains multiple sections and continuous footnote numbering, the 
footnote numbering will be reset according to the InDesign footnote options.

Although InDesign doesn’t support continuous footnote numbering across sections, consider setting 
the InDesign Output Format in a Job Option to Book in cases where footnotes must be numbered 
continuously. A script addition to the job option could then automatically set the Start At footnote 
numbering for each InDesign document that is published as part of the book. Alternatively, you could 
make this change manually after-page composition.

InDesign Footnotes
We’ve already seen that InDesign footnotes will always restart their numbering at the 
beginning of each section, spread or page. In addition to this restriction, InDesign 
footnotes always appear in the same text frame as the in-text reference and do not span 
multiple columns unless the footnote reference is in a paragraph that spans multiple 
columns. This means, for example, that footnotes inserted as part of an Element by the 
author, will sit within the Element Content frame. 

InDesign further lacks support for use of footnotes in tables, or nesting of footnotes within 
footnotes. Also, footnotes are not affected by text wrap, which means that where they 
interact with floating elements with text wrap, the footnote text will not wrap around the 
Element.

Set the Footnote Reference Number Character 
Style to [None] to avoid formatting errors
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Endnotes
InDesign has no support for endnotes. However, where endnotes are inserted by the 
author in Word, endnotes are published as footnotes (vice versa in EPUBs), and numbered 
sequentially based on the InDesign template’s Document Footnote Options. The Endnote 
Reference in Word formats the reference number in the text. As best practice, you might 
want to add similarly-named character styles to the InDesign template and format the 
endnotes using the Endnote Text paragraph style.
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InDesign CS6 has improved EPUB export features that Typefi Publish uses as 
the basis for creating a flexible and streamlined EPUB production workflow. 
With Typefi Publish and InDesign CS6, you have greater control over how 
your EPUB eBooks are created. Within an InDesign template you will be 
able to define how your elements are rasterised for on-screen viewing. 
Also within the template you will create export presets that define just the 
options you need for your EPUB export workflow. This guide will teach you 
step-by-step how to use the EPUB Export Script.

New Process
There are a number of changes to EPUB Export in Typefi Publish 6 when compared 
to Typefi Publish 5.x (InDesign CS5.5). First and foremost are the changes to EPUB 
Export parameters in InDesign CS6. Second is the direct support for EPUB Export in 
Typefi Publish 6 (no more secondary script to install). This guide shows you how to set up 
a job for EPUB Export in Typefi Publish 6, along with notes on how it has changed from 
Typefi Publish 5.x (InDesign CS5.5).

EPUB Export for InDesign CS 6 
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If necessary, we will supply a script which will convert your Publish 5 EPUB presets to 
Publish 6-compatible presets. Place the ‘UpdatePresetsToPublish’ script in your InDesign CS6/Scripts/
Scripts Panel folder. The script can be run from the Scripts panel within InDesign. The script expects 
there to be one document open (e.g. your template). The script seeks out any preset tables in the open 
document and will attempt to map the parameters in the preset to Publish 6 equivalents. When the 
script is done, your preset tables should now work with Publish 6. 
Note: In addition to converting the presets, you must also ensure that the preset tables get composed 
on to a page by the Publish 6 Engine. This is a major change from Publish 5, in which the presets were 
expected to be on a master page, but did not have to get put in to an ‘active’ page of the composed 
document. This change allows the presets to take advantage of Typefi Fields. Fields need to be on 
a composed page in order to receive an actual value. The most common practice is to put the preset 
tables on a master page that is used by each document that is generated (for example, the title page 
master or the cover page master of a book). The Publish 6 Engine will seek out any EPUB Presets that are 
on a composed page of the generated InDesign document.

Step 1: Setting up the EPUB Preset Frame
The EPUB Export script refers to one or more text frames that contain one or more ‘preset 
tables’. These preset tables contain the EPUB Export Options that would normally be 
entered by hand when exporting an EPUB using the desktop version of Adobe InDesign.

The EPUB Export script finds these preset tables by the name of the text frames that hold 
the preset tables. These text frames are all named ‘EPUB Presets’ via the Layers panel. 
The text frames should also reside on a specially-created ‘Presets’ layer. Anything on the 
Presets layer will be automatically moved to the pasteboard before EPUB export. This will 
effectively make those items invisible when exporting the EPUB. (Hiding or making the 
layer non-printable is not enough to exclude an item from EPUB Export.)

Each table is a single preset with a unique name. If there is more than one preset table, 
then the EPUB Export script will export an EPUB file for each preset. The EPUB file name 
will contain the preset’s name so you know which EPUB file goes with each preset.

These preset tables only need to contain the parameters you wish to change from the default settings. For 
example, if you only wish to change the resolution of the raster graphics from the default 150ppi to 
96ppi, then your preset would only contain a row for the name of the preset and then one row for the 
Resolution parameter.

The actual contents of the EPUB Presets text frame are composed via CXML during the 
job run. This allows the user to make use of variable data such as filling in the author, 
publisher, or ISBN for each job that is run. It is easiest to set up the ‘EPUB Presets’ named 

Comparison of the EPUB presets and the InDesign 
dialog used in manual EPUB creation

The Layers panel showing the named text frames 
containing the preset and metadata tables
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text frame as a Typefi Floating Element. This floating element can show up on any ‘live’ 
page of the InDesign document.

The EPUB Presets Table is available as an InDesign ‘snippet’ that will be provided to you 
upon request. It is called ‘EPUB Preset Default Values.idms’.

 ■ Within your InDesign EPUB template, create a new layer via the Layers panel and name it ‘Presets’
 ■ Ensure other layers are locked and the ‘Presets’ layer is selected
 ■ Choose File>Place, locate the snippet, and put it on the title master or another suitable master page 

(one always used in composition) in the ‘Presets’ layer

 ■ Name the text frame ‘EPUB Presets’ via the Layers panel by clicking on the triangle next to the layer that 
contains the text frame (the frame will be called ‘<text frame>’)

 ■ Click once on the name, pause, then click again and rename it ‘EPUB Presets’

EPUB Export as a Book job: If the EPUB is being exported as a Book job, then this EPUB Preset text 
frame needs to be composed within the first InDesign document that appears in the InDesign Book file 
(i.e. the first Section of the CXML). EPUB Preset frames that are in any of the other documents of the 
book will be ignored.

Step 2: EPUB Export Table Options
The InDesign EPUB Export Options are organised into three sections: General, Image, 
and Contents. We will cover all the available preset options in the same order as they 
are displayed in the EPUB Export Options window. The EPUB Presets Table allows you to 
define and customise your export options.

 ■ The first step is to name your EPUB Preset (very important). In the very first cell of the EPUB Export 
Table, you will see ‘Default’, and this is where you enter the name of your EPUB Preset (whatever you 
like). Replace ‘Default’ with the name of your Preset. This is the value that will be added to the Job 
Option that will be created within your TPS EPUB Project (and it must match exactly). We will discuss 
that in the next section.

 ■ The next step is to configure your EPUB Export Options within the EPUB Export Table. Shown below 
are all the variables that are available to you as EPUB Export Options. Change the values in the table for 
your specific workflow.

If the text/table frame is not on the correct layer, select the text frame, 
and within the Layers panel you will see a square icon at the far right that 
indicates the selected item. Drag the icon to the Presets layer you created.
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EPUB Errors on Export
Sometimes there can be errors in an EPUB Export preset that will still successfully create an 
EPUB document. If the EPUB Export script determines that an EPUB will export with errors, 
the script can do one of two things:

 ■ Export the EPUB as it is and log an error in the Job log, or
 ■ Abort the EPUB export and log an error in the Job log. By not exporting the EPUB as expected, this will 

call attention to a problem with your EPUB Export preset.

Add the following row to your preset if you wish to Abort on Error:

Abort on Error Yes

The default action is to always export the EPUB, even if there are errors with the EPUB 
Export preset.
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EPUB Export Options: General EPUB

~ General EPUB Available Options Default Value Comments

Include Document Metadata true | false true To add Metadata to your InDesign Document, select File > File Info. In the Description Tab, 
enter the Metadata you would like to have exported to your EPUB. Only the following fields 
are supported: Document Title, Author, Description, Keywords, and Copyright Notice.

Add Publisher Entry text string   Specify the publisher information that appears in the eBook metadata. You can specify a URL 
for the publisher so that someone who receives the eBook can visit the publisher’s website.

Unique Identifier text string   Every EPUB document requires a unique identifier. You can specify the unique identifier 
attribute. If you leave this field empty, a unique identifier is automatically created.

~ EPUB Cover

EPUB Cover No Cover Image | 
Rasterise First Page | 
Use Existing Image File

Rasterise First Page The Default EPUB export preset uses the Rasterise First Page to create the cover page in the 
eBook. To use a different cover image, change the value to “Use Existing Image File” and then 
specify the file path (see next row).

Use Existing Image File Path File path to the cover 
image file

  This option is not defined by default, so if you would like a different cover image, enter the 
path to the image here. For example: C:\Typefi\Publish\Filestore\ePub\Images\Cover.eps.
NOTE: For InDesign to use this field, you must enable the “Use Existing Image File” option (see 
row above).

~ Ordering

Ordering Based on Page Layout | 
Same as XML Structure | 
Same as Articles Panel

Based on Page Layout This is the order in which the contents of your publication will be ordered within the EPUB file. 
There are three options:
Based On Page Layout: InDesign determines the reading order of page objects by scanning 
left to right and top to bottom. In some instances, especially in complex multicolumn 
documents, the design elements may not appear in the desired reading order. Use a 
dedicated HTML or XML editor (such as Dreamweaver or Oxygen) to open the EPUB file and 
rearrange and format its contents.
Same As XML Structure: The order of the tags in Structure View determines the reading order. 
Same As Articles Panel: The order of elements in the Articles panel determines the reading 
order. Only the checked articles are exported.
NOTE: Inline elements do not appear in the Articles panel. They are exported in the order in 
which they appear within the text.

~ Formatting Options
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~ General EPUB Available Options Default Value Comments

Book Margin Units em | pixel em Em is the default unit of measurement. You can use pixels if you prefer. An em is a unit 
of measurement that’s equal to the currently specified text size of the eBook reading 
device. So when a reader changes the text size on their eBook reader, all the text will resize 
proportionally when you use the em unit. InDesign considers 12pt equal to 1em. So 24pt 
is 2em, and so on. By using em units for the book margins, text, and images, your eBook 
layout will proportionally adapt to the dimensions of different screen sizes. The pixels unit 
of measurement, on the other hand, is a fixed measurement system. As a result of using this 
system, your eBook layout may not adapt as well when viewed on different screen sizes.
NOTE: Only Adobe-supported eBook readers currently utilise the Book Margin Units setting. 
It’s not compatible with the Apple iBooks app or the Amazon Kindle.

Book Margin number 0.5 Specify the book margin in Ems or pixels. Specifying margins in Ems is better for multiscreen 
compatibility. The same value is applied to all margins: top, bottom, left, and right.

Bullets Map to Unordered Lists 
| Convert to Text

Map to Unordered 
Lists

Select Map To Unordered List to convert bulleted lists into HTML list items, which use the <ul> 
tag. Select Convert To Text to format using the <p> tag with bullet characters as text. If you 
have used native InDesign auto-bullets, subbullets are also included.
NOTE: This option only applies to bulleted lists that were created using the Bullets and 
Numbering feature of InDesign. Lists that were created manually are not converted to HTML 
lists.

Numbers Map to Ordered Lists | 
Map to Static Ordered 
Lists | Convert to Text

Map to Ordered Lists Determines how numbered lists are created in the EPUB file. There are three options:
Map To Ordered Lists: Converts numbered lists into HTML ordered lists using the <ol> and <li> 
tags.
Map To Static Ordered Lists: Converts numbered lists into HTML ordered lists using the <ol> 
and <li> tags and assigns a <value> attribute to each paragraph based on its current number 
in InDesign.
NOTE: When using the Map To Ordered Lists and Map To Static Ordered Lists options, the 
actual numbers are not included in the HTML file. Instead they are rendered by the eBook 
reader.
Convert To Text: Converts the numbered lists into paragraphs that begin with the paragraph’s 
current number. The number is included as text in the HTML file.
NOTE: This option only applies to numbered lists that were created using the Bullets and 
Numbering feature of InDesign. Lists that were created manually are not converted to HTML 
lists.

EPUB Export Options: Image

~ Image Available Options Default Value Comments

Preserve Appearance from 
Layout

true | false true True will inherit the image object attributes from the layout.
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~ Image Available Options Default Value Comments

Resolution (ppi) 150 | 300 | 72 | 96 150 Specify the resolution of the images in pixels per inch (ppi). While operating systems have 
standardised on either 72 ppi or 96 ppi, mobile devices range from 132 ppi (iPad), to 172 ppi 
(Sony Reader), to over 300 ppi (iPhone 4). You can specify a ppi value for each object selected. 
Values include 72, 96, 150 (average for all eBook devices today), and 300.
TIP: In most cases, using a resolution of 150 ppi for all images will provide optimal image 
display for the majority of the eBook reading devices currently on the market. You might want 
to specify 300 ppi for images that contain a lot of detail, such as maps. This provides enough 
image data to allow a user to zoom in on an image to view its details.

Image Size Fixed | Relative to Page Fixed Specify whether the image size should be fixed or resized relative to the width of the 
page. Relative To Page Size sets a relative percentage value based on the size of the image 
relative to the InDesign page width. This option causes the images in the EPUB file to rescale 
proportionally, relative to the width of the reading area. If you specify Fixed, the images are 
exported at their current dimensions (as measured in pixels).

~ Image Alignment and Spacing

Image Alignment Center | Left | Right Center Specify how you want the images to be aligned relative to the page.

Image Spacing Unit em | pixel em Em is the default unit of measurement. You can use pixels if you prefer. This option applies to 
the following two options.

Image Space Before number 0 Specify how much space you want to appear above the images in the EPUB file.

Image Space After number 0 Specify how much space you want to appear below the images in the EPUB file.

Insert Page Break true | false false Determine whether or not you want a page break inserted before, after, or before and after 
images. If you specify True, determine where you want the page breaks to occur by specifying 
an option in the following row.
NOTE: When you specify True, the page breaks are defined in the CSS file using the page-
break-before and/or page-break-after properties.

Image Page Break After Image | Before 
Image | Before and After 
Image

  Specify where you want the page breaks to occur. Page breaks can be inserted Before Image, 
After Image, or Before and After Image.

Settings Apply to Anchored 
Images

true | false false Specify True to apply the image options to all anchored objects in the document.
TIP: If your document contains anchored images that don’t have specific Object Export 
Options applied (Object > Object Export Options), specify True to be sure they are exported 
with the same options the other images are using.

~ Image Conversion

Image Conversion Automatic | GIF | JPEG 
| PNG

Automatic Determine whether the optimised images in your document are converted to GIF, JPEG, or 
PNG. Choose Automatic to let InDesign decide which format to use in each instance. Choosing 
PNG disables the image compression settings.
TIP: Use PNG for lossless images or for images that include transparency.

~ GIF Options
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~ Image Available Options Default Value Comments

GIF Options Palette Adaptive (no dither) | 
System (OS X) | Web | 
System (Win)

Adaptive (no dither) Lets you control how InDesign handles colours when optimizing GIF files. The GIF format 
uses a limited colour palette, which cannot exceed 256 colours. Choose Adaptive to create a 
palette using a representative sample of colours in the graphic without any dithering (mixing 
of small spots of colours to simulate additional colours). Choose Web to create a palette of 
web-safe colours that are a subset of Windows and OS X system colours. Choose System (Win) 
or System (OS X) to create a palette using the built-in system colour palette. This choice may 
cause unexpected results.

GIF Options Interlaced true | false false Select Interlace to load the images progressively by filling in missing lines. If this option is not 
selected, an image might look fuzzy and gradually becomes clear as the image reaches full 
resolution.
NOTE: You will likely not notice this effect when using current eBook reading devices, because 
their graphics cards adequately support the fast display of images. Historically, interlaced GIF 
graphics were used on websites that could take a while to load. Rather than display a blank 
area before the image can load, the image is loaded progressively.

~ JPEG Options

JPEG Options Image Quality High | Low | Medium | 
Maximum

High Determines the trade-off between compression (for smaller file sizes) and image quality for 
each JPEG image created. Low produces the smallest file and lowest image quality.

JPEG Options Format Method Baseline | Progressive Progressive Determines how quickly JPEG graphics display when the file containing the image is opened 
on the web. Choose Progressive to make the JPEG images display gradually and in increasing 
detail as they are downloaded. (Files created with this option are slightly larger and require 
more RAM for viewing.) Choose Baseline to make each JPEG file display only after it has been 
downloaded; a placeholder appears in its place until the file displays.
NOTE: This option only applies to the Web viewing experience, not to eBook reading devices.

Ignore Object Export 
Settings

true | false false Specify True to ignore the Object Export Options that are applied to individual objects.
TIP: If you have applied Object Export Options to specific elements (such as tables and maps), 
specify False to ensure the most optimal settings are used for each element.

EPUB Export Options: Contents

~Contents Available 
Options

Default Value Comments

Format for EPUB Content XHTML | DTBook XHTML Specify whether you want to use the XHTML or DTBook format. DTBook is a specialised format that 
is intended for sight impaired end readers.

~ Contents
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~Contents Available 
Options

Default Value Comments

Use InDesign TOC Style true | false false Specify True if you want to generate a table of contents based on the specified TOC style 
(identified in the following row). Choose Layout > Table Of Contents Styles to create a TOC style for 
your eBook.
NOTE: When this option is set to True, InDesign generates two TOC types: a traditional table of 
contents and a navigation guide. The traditional table of contents appears as a page in the eBook 
and each entry is a clickable hyperlink. No page numbers appear in the generated TOC. The 
navigation guide appears as a menu in an eBook reader. Each eBook reader displays this menu 
differently.

InDesign TOC Style Name TOC Style Name   If you specified True in the row above, identify the TOC style name you want to use to build the 
table of contents and navigation guide in the eBook.
NOTE: The default settings do not use a TOC style, so this cell is empty in the presets table.

Break Document at Paragraph Style true | false false Specify True to split the InDesign document into multiple HTML files (within the EPUB file) at a 
specified paragraph style. Splitting results in a larger number of HTML files in the EPUB package, 
which can be helpful for breaking up long files and increasing the performance of eBook reading 
devices.
TIP: Use this option to force page breaks in an eBook. Since a separate HTML file is created at each 
occurrence of the specified paragraph style, the eBook reading device is forced to load each file it 
encounters as a new page. As a result, the content is loaded at the top of the next page. The text to 
which the specified paragraph style is applied appears at the top of each HTML file.

Paragraph Style Name A valid 
Paragraph Style 
Name

  If you specified True in the row above, identify the paragraph style name you want to use to break 
the document up.
NOTE: The default settings do not break a document at a paragraph style, so this cell is empty in 
the presets table.

Place Footnote After Paragraph true | false false Specify True to place footnotes after their associated paragraph. If you specify False, the footnotes 
are converted to endnotes, which appear at the very end of the publication.
NOTE: The footnote reference numbers automatically become clickable hyperlinks in the EPUB file. 
The corresponding number in the footnote reference also becomes a clickable hyperlink that takes 
you back to the reference number.
TIP: To format the footnote reference numbers in an EPUB file, you need to apply a character style 
to them in the InDesign document. This in turn creates a corresponding rule in the CSS file that 
determines how the reference numbers are formatted in the EPUB file. To automatically apply 
a character style to the reference numbers, choose Type > Document Footnote Options. In the 
Footnote Options dialog box, specify a character style in the Footnote Reference Number In Text 
section. You can also specify a paragraph style that’s applied to the footnote text.

Remove Forced Line Breaks true | false false Specify True to remove all soft-returns in the exported eBook.

~ CSS Options      

CSS Options Generate CSS 
| Use Existing 
CSS File | Style 
Names Only

Generate CSS Cascading Style Sheets (CSS) are a collection of formatting rules that control the appearance of the 
contents of an HTML file. When you use CSS to format HTML content, you are separating content 
from presentation.
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~Contents Available 
Options

Default Value Comments

Comments     The following three options are only considered if “Generate CSS” is specified in the row above.

Include Style Definitions true | false true Specify True to create a list of CSS styles (with attributes) that can be edited in the exported EPUB 
file. This is the quickest way to format the contents of an EPUB file.

preserveLocalOverrides true | false true If True is specified, local formatting such as italic or bold is included.
NOTE: Enabling this option results in the generation of generic CSS rules. If your document has 
many style overrides, this can make the process of formatting an EPUB file quite complex and time 
consuming. To streamline the formatting process, apply character styles instead of relying on local 
formatting.

Include Embeddable Fonts true | false true Specify True to include all embeddable fonts in the EPUB file.
NOTE: Fonts include embedding bits that determine if they are embeddable or not. Only 
OpenType and TrueType fonts can be embedded. PostScript fonts cannot be embedded within an 
EPUB file.

Use Existing CSS File Path File path to 
external CSS file

  This option only needs to be defined if Use Existing CSS File is specified in the CSS Options row 
above. Specify the file path of the existing CSS style sheet.
NOTE: On OS X, you must use colons (:) for the separators in the file path. On Windows, you must 
use backslashes (\) for the separators. InDesign does not check whether the CSS exists or is valid, 
so you’ll want to confirm your CSS setup.
TIP: To be sure you use the correct file path, manually export an EPUB file from InDesign. In the 
Contents category of the EPUB Export Options dialog box, specify the Use Existing CSS File option 
and then click Choose to locate a CSS file. After locating the file and clicking Open, copy the file 
path that’s inserted in the field. Paste the file path into the table in your template.
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Step 3: Choosing an EPUB Preset for a Job Option in 
Typefi Publish
To run your newly configured EPUB Export Script, you must define your Job Option with 
your Typef Publish Project. You may do this as follows:

 ■ Within your Typefi Project, go to Job Options, and Select> New to create a new Job Option.
 ■ Name your Job Option and select your options. If you are running your EPUB Export Script at BookEnd, 

be sure to select Book as your InDesign Output Format.
 ■ Select and add the sections you want added to your EPUB.
 ■ Under Scripting Options, select Override Script Presets
 ■ Add the location of your ‘Designer Scripts’ at either book.end or document.end. If you have created a 

single EPUB folder as recommended earlier in the section titled ‘EPUB Export Script’, your script location 
should be as follows:

 ● OS X Server: Scripts/EPUB/BookEnd.jsxbin or Scripts/EPUB/DocumentEnd.jsxbin
 ● Windows Server: \Scripts\EPUB\BookEnd.jsxbin or \Scripts\EPUB\DocumentEnd.jsxbin

The EPUB Presets are stored within an InDesign Designer template. You may have more 
than one EPUB Preset stored in the Designer template. An EPUB Preset is specified in a 
job option’s ‘Script Arguments’ box. Scroll to the bottom of the list of options. You should 
find a single-line text box labeled ‘Script Arguments’. This is where you add the name of 
the EPUB Preset that you specified in ‘Step 2: EPUB Export Table Options’. You also have to 
option to generate a log file to check for errors by adding the ‘debug’ instruction after the 
preset name.

Here is an example that would specify the EPUB Preset name ‘ePub Textbook’:

Script Arguments: EPUB Preset: ePub Textbook; debug

You may only specify one EPUB Preset per job option. If the EPUB Preset you specify in 
the Script Arguments does not exist in the Designer template used for this job option the 
default values for EPUB Export will be used.

Step 4: Generate your EPUB
Now that you have completed all the necessary steps to configure your EPUB Export you 
are ready to run your Typefi Publish Job Option which will create produce your EPUB, 
InDesign Document or Book, and PDF document (if selected in the Job Option).

To view your EPUB you must have software such as Adobe Digital Editions, Calibre or a 
number of other software applications. Wikipedia has a very comprehensive list of EPUB 
reading and editing software listed here: Wikipedia EPUB.

http://en.wikipedia.org/wiki/EPUB#Software
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Typefi Designer adds five additional preference categories to InDesign’s 
Preference dialog. To access Typefi preferences categories, select InDesign’s 
Preferences from the Edit (Windows) or InDesign menu (OS X).

Most of the preferences affect the open document. If no document is open, the preferences are stored 
as InDesign application-wide default preferences that applied to new documents. This has an effect on 
the ‘Typefi Borders’ and ‘Typefi Anchors’ preferences, which show a check-box to save the document 
preferences as InDesign application-wide preferences only when no document is open, and where 
‘Use Defaults’ means to use the InDesign application-wide preference settings in case the preferences 
of a document are edited, but to use the Typefi default settings in case the InDesign application-wide 
preferences are edited. The only preference pane where the preference settings are not necessarily 
document-wide is ‘Typefi Preferences’.

Typefi AutoFit
The Typefi AutoFit preferences ensure that AutoFit relationships and resize settings work 
dynamically. AutoFit is enabled by default (see also "AutoFit tool" on page 11).

Disabling Typefi AutoFit means that AutoFit relationships and resize settings don’t work 
interactively in the InDesign template. In addition, disabling the setting could prevent the 
proper handling of AutoFit relationships and resizing of frames during page-composition.

A situation in which disabling AutoFit could be useful is when a lot of page items with 
AutoFit relations need to be re-arranged without getting the relations updated (or also if 
auto-resize, or even limit checks, might temporarily hinder you in some tasks). 

Allow single column text frames to collapse is a setting that is disabled by default. 
Enabling this setting allows single column text frames with a single column to shrink to 
3pt height (or as close as possible) when AutoFit is enabled. With the default setting as 
disabled, a single column text frame will use a minimum height depending on the font 

Typefi Preferences

The extra Typefi preferences that appear in InDesign Preferences

InDesign Preferences > Typefi AutoFit.
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height for the first character of a text frame, i.e. the text cursor will then be completely 
visible if the user clicks in such an empty text frame.

Typefi Hyperlinks 
Cross-references are automatically hyperlinked. Hyperlinks enable a user of a document 
to jump from the hyperlink location to a source elsewhere in the documents and can be 
inserted as interactive links in a PDF created from InDesign. 

The Hyperlink Character Style setting only affects cross-references that have hyperlinks 
associated with them and formats these cross-references with the attributes defined by 
the character style, not the style itself. This means that the character style is not actually 
applied to the text. 

The Hyperlinks Appearance settings have an impact on cross-references that are 
hyperlinks. They do not have an impact on normal InDesign hyperlinks.

The Appearance Type sets the visibility of the hyperlinks. A visible hyperlink is marked by 
a rectangle surrounding the hyperlink text. The appearance of this rectangle is controlled 
by the Width, Colour and Style settings. The Highlight setting relates to the appearance 
of the link when the link is clicked. Invert will reverse the colours, Outline will display a 
stroked rectangle and Inset (see screenshot) will give the appearance of a button being 
pushed when the link is clicked.

Typefi Borders
Typefi Borders are the visual appearance of Typefi Frames and Master Elements and 
Instances (see "Master Element" on page 53). Typefi frames are distinguished from 
InDesign frames through their border colour, width and opacity.

The Typefi Preferences setting for Typefi Borders sets the frame border appearances 
as well as Element Instance and Prototype appearance General border width and 
transparency percentage may be changed.

To edit the Typefi Border settings:

 ■ In InDesign Preferences choose Typefi Borders.
 ■ Set the default Stroke Weight for the Borders.
 ■ Set the default Opacity for the Borders.

Note: InDesign hyperlinks are not formatted by this feature. 

Choosing the Character Style for hyperlinks

Rollover behaviour of a hyperlink set to Inset

InDesign Preferences > Typefi Borders, with a new choice 
to save the colour choices for all documents
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To override the default opacity for certain Typefi Borders:

 ■ Enter an Opacity percentage for the individual Border Type.

To view Typefi Borders in InDesign:

 ■ Enable Show Typefi Borders and ensure View > Show Frame Edges in InDesign is selected, also ensure 
that View > Overprint Preview is disabled and View > Screen Mode is set to Normal

(Alternatively, select Show Frames from the Typefi Elements panel menu).

To view a selective range of Typefi Borders in InDesign:

 ■ Enable or disable the view setting for individual Border Types using the checkboxes in the Typefi 
Borders preferences

 ■ Enable Show Typefi Borders.

To specify the default colours for borders in future Typefi templates:

 ■ Choose the border weight, colours, and opacity you prefer
 ■ Enable the Save as Default Settings choice (see previous screenshot)

To reset the Typefi Border appearances to their default stroke weight, opacity and colour:

 ■ Choose InDesign Preferences > Typefi Borders
 ■ Click Use Defaults.

Typefi Anchors
Typefi Anchors are the lines and markers that connect an Element with their reference in 
the Text.

The Typefi Anchor preferences define the colour, and weight of the lines and markers.

To edit the colour of the Anchor markers:

 ■ Click the colour drop-down
 ■ Pick a colour from the list

Marker and Line stroke weight and opacity of colour can be changed:

Anchor Marker
The Anchor Marker is the circular mark linked to the Element, and its size can be increased 
to a maximum circular dot of 8pt.

If a document is open, the panel has an additional check-box: ‘Save as 
default settings’. In the context of an open document, ‘Use Defaults’ means 
to use the settings that had been used as the InDesign application-wide 
default settings.

Typefi Element and Anchor line and marker 
and its appearance in Story Editor.
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To edit the Anchor Marker:

 ■ Change the Weight and Opacity settings in the Typefi Anchor preferences

Anchor Line
The Anchor Line is the line that connects the Marker to its reference point in the text, and 
which can be increased to a maximum stroke weight of 8pt.

To edit the Line:

 ■ Change the Weight and Opacity settings in the Typefi Anchor preferences

To View Typefi Anchors in InDesign:

 ■ Enable or disable the Show Typefi Anchors setting

To store the new settings as InDesign defaults:

 ■ Click Save as Default Settings

To restore the Typefi Anchor preferences to their original settings:

 ■ Click Use Defaults

Typefi Preferences
The Typefi Preferences contain settings for Counter Format Language.

InDesign Preferences > Typefi Anchors.

InDesign Preferences > Typefi Preferences
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In order to ensure that your Project template is fully functional, test the 
template. Testing requires access to content and set-up of job options.

To test a template, create a new Typefi document with the Typefi Writer in Word and insert 
the sections you’d like to test and some sample text and Elements etc. in each section. Use 
the Print Typefi Document command to test to run the content into the template. From 
the Jobs section of your project, check out the InDesign file(.indd) that was generated and 
review this file.

Please refer to Typefi Publish 6 Writer User Guide to learn how to create test content. Refer 
to Typefi Publish 6 Server User Guide to learn how to create Job Options.

Testing your Template
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